Get meeting/webinar registration API

I can’t seem to find where to obtain the registration URL from the API docs.

I would like the registration link after having created an event via the API, such as you can for join_url and start_url

Any help appreciated!

@marcus The Get Meeting API call returns these results. For open meetings it’s the “join_url” parameter and for meetings requiring registration, it’s the “registration_url” parameter.

1 Like

@OregonDean, thanks but that’s the call I’m using currently.

registration_url isn’t returned even with meeting approval_type = 2

Also the docs page you linked doesn’t describe registration_url either as a response variable.

@marcus … you are correct that the documentation does not mention registration_url or join_url … but in my testing, they are returned (one or the other depending on the meeting type).

In my testing, a type 2 meeting returns registration_url, see below.

But please note I have found another problem with the API when you use it to create a meeting requiring registration (type 1 and 0) - this may be your root problem and why registration_url is not returned. Double-check your response. (Note that for the meeting below I used the API to create it, but then manually edited the meeting settings via the admin website panel to make registration required.)

My observation is that new meeting API calls requesting approval types 0 & 1 always result in a new meeting being created – but always with approval type 2, a non-registration open meeting. See discussion and code here.

{
“uuid”: “redacted”,
“id”: redacted,
“host_id”: “redacted”,
“topic”: “Test API Meeting - one device”,
"type": 2, :grinning:
“status”: “waiting”,
“start_time”: “2020-06-15T15:00:00Z”,
“duration”: 60,
“timezone”: “America/Los_Angeles”,
“agenda”: “My agenda goes here”,
“created_at”: “2020-06-11T19:25:32Z”,
“start_url”: “https://us02web.zoom.us/s/redacted”,
“join_url”: “https://us02web.zoom.us/j/redacted”,
"registration_url": “https://us02web.zoom.us/meeting/register/redacted”, :grinning:
“password”: “redacted”,
“h323_password”: “redacted”,
“pstn_password”: “redacted”,
“encrypted_password”: “redacted”,
“settings”: {
“host_video”: true,
“participant_video”: true,
“cn_meeting”: false,
“in_meeting”: false,
“join_before_host”: true,
“mute_upon_entry”: false,
“watermark”: false,
“use_pmi”: false,
“approval_type”: 0,
“audio”: “both”,
“auto_recording”: “none”,
“enforce_login”: false,
“enforce_login_domains”: “”,
“alternative_hosts”: “”,
“close_registration”: false,
“registrants_confirmation_email”: true,
“waiting_room”: true,
“global_dial_in_countries”: [
“US”
],
“global_dial_in_numbers”: [
{
redacted
}
],
“contact_name”: “redacted”,
“contact_email”: “redacted”,
“registrants_email_notification”: true,
“meeting_authentication”: false
}
}

1 Like

@OregonDean turns out what was going wrong for me was stupidity… I was checking the output from another test meeting I made via PostMan which had approval_type 2, which logically wouldn’t have a registration link. Thanks for getting me on the right track!!

Verifying the one I made programatically does in fact have a registration_url

I double-checked also what you mentioned, thinking maybe the meeting ID had changed… but I don’t think so. In my case. I do manage to successfully create a new meeting with approval_type = 1 and my meeting response is correct too.

1 Like

And me too … simple error in my code that @Tommy found in this discussion but was too obvious for me to see in my own code.

1 Like

Better that it’s a bug in ours than waiting for a bug fix on their side :slight_smile:

Thanks for your input. Case closed!

1 Like

Thanks for your help @OregonDean! :slight_smile:

Happy to hear you have the issue sorted out @marcus!

-Tommy