GET /meetings/{meetingId}/recordings cannot deal with UUIDs that contain forward slashes


#1

I am using the past_meetings endpoint to look up all instances of a meeting_id. https://api.zoom.us/v2/past_meetings/.../instances

Once I get those, I’m checking for recordings against the /meetings/…/recordings endpoint using a UUID. The UUID contains a slash and the API just fails with the call.


#2

Hi @samly,

Have you tried encoding the UUID?

Thanks


#3

Yes. The API endpoint doesn’t seem to accept it even if it’s encoded. I can share a Meeting UUID in private if that’s an option if you want to test it out.


#4

Yes please send us the accountID and UUID at developersupport@zoom.us and we’ll take a look.

Thanks


#5

I’m having the same issue with a uuid that has a slash as the first character. Tried urlencoding but that doesn’t help. I receive 404 either way for a known existing recording.


#6

@Michael_Purnell @Zoom_Ingester Figured out a workaround. If you encode the UUID twice, it works.
So, now my UUID path parameter is set like so: encodeURIComponent(encodeURIComponent("/sTuPiD_UuIDbeGinS_w1thSl@sh"))


#7

Hi @samly,

Glad that you were able to find a workaround, we’ll address it with our Engineers about the “/” in the UUID.

Thanks