Get Webinar Details - Webinar does not exist

Using this template helps us debug your issues more effectively :slight_smile:

I’m trying to use the endpoint: Get Webinar Details endpoint ( /metrics/webinars/{webinarId} ). The Zoom documentation says that I can use either the “webinarId” or the “webinarUUID”, I’ve tried both and I get an exception “Meeting does not exist”. I’ve used the webinarId: 89404961187, as well as the following UUIDs:

This webinar occurred today August 5th, 2021. I joined as host and two additional participants, for a total of 3 participants. The webinar lasted about 20 seconds. When I try to get the details, I always get the exception “Meeting does not exist”

org.springframework.web.client.HttpClientErrorException$NotFound: 404 : [{“code”:3001,“message”:“Meeting does not exist: 89404961187.”}]

I get this after running the API call using REST template in Java Spring boot.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
Knowing the endpoint/s can help us to identify your issue faster. Please link the ones you need help/have a question with.

Which Endpoint/s?

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Request URL / Headers (without credentials) / Body
  2. See error

Screenshots (If applicable)
If applicable, add screenshots to help explain your problem.

Additional context
Add any other context about the problem here.

Perhaps I missed it, but I didn’t see this in the documentation at all. The fix is to include a get parameter ?type=past. So the endpoint would be something like:


This solved my issue.

Glad you were able to resolve it!