Getting Custom Question Error While creating the Registrant in Zoom Webinar

#1

Image1

I have created a Custom question with my webinar which you can see in the above screen shot. Now I am going to create a registrant with that webinar and passing the values

Body:
{
“address”: “chd”,
“city”: “chd”,
“comments”: “test”,
“country”: “ind”,
“custom_questions”: [
{
“title”: “What is your role in the study?”,
“value”: “Manager”
}
],
“email”: "nip19@gmail.com",
“first_name”: “nip”,
“industry”: “it”,
“job_title”: “soft”,
“last_name”: “trip”,
“no_of_employees”: “15”,
“org”: “digi”,
“phone”: “123456”,
“purchasing_time_frame”: “123”,
“role_in_purchase_process”: “abc”,
“state”: “chd”,
“zip”: “160102”
}

But it gives me an error {“code”:300,“message”:“The parameter is required in custom_questions: What is your role in the study?”}…

But if I am deleting the custom question and not sending the values of custom questions with my api call then its working fine.

But I don’t want to delete the custom questions from there. Please let me know which value should I need to pass in the custom questions parameter.

Thanks in advance.

#2

Hi @nipun.tripathi,

We are currently working on your issue and will get back to you with updates soon

Thanks,
Ojus

#3

Hi @Ojus How much time it will take. I have a meeting with my client and I have to give a demo with Zoom webinar… So Please try to fix it asap…

Regards
Nipun Tripathi

#4

Hi @nipun.tripathi,

Please accept my apologies for the delay.

Lets us do some basic diagnostics:

  1. Please make sure that the “title” in your request body exactly matches with the question that you have entered in the web portal?

  2. If you have selected your answer type as "Single Answer", please note that the value you provide in your request should be present in your web portal. Please note that these values are case sensitive as well.
    Please refer to the following screenshot:
    26%20PM

In the above example, if my request body contains a value “sales” as the answer, it will send a '300' error. Similarly, if my value is Manager instead of ‘manager’, a ‘300’ error is expected. If you need to add any value to your answer, I would recommend selecting the type as "short answer"

Please let me know if that resolves your issue.

#5

I got your point. Its working now thanks for you help.