Getting error Authenticated user has not permitted access to the targeted resource while creating meeting

Hi There,

We are receiving an error while creating meeting,
Authenticated user has not permitted access to the targeted resource.

however we get this error only when user authenticate zoom account whithout checking
Allow this app to use my shared access permissions

and if user checks this checkbox we dont get any error while creating metting and meeting getting
created normally.

we are usig following scopes in our app

so can you please tell me how to handle this situation and do user need to checkAllow this app to use my shared access permissions while creating meeting?

@jovy,

Happy to help! Yes, you are correct! You need to check allow this app to use my shared access permissions to authorize the app. Also, it looks like you made some changes to the scope so you will need to regenerate the Publishable URL as well. I’ve linked our help documentation below for your reference:

Thanks @donte.zoom
Is it possible that user dont need user to check allow this app to use my shared access permissions, to create meeting in our app?

We had a meeting with zoom testing team member and he said to create meeting, he did not need to check allow this app to use my shared access permissions in other app he had tested.

1 Like

we have same issue and Zoom functional review is stuck because of this.

@jovy, did the zoom functional review team accept granting “shared access” as a solution?

Hi @prashanth1

We had a call with zoom testing team and discussed this issue with them,

issue was we need to remove schedule_for parameter while creating meeting because as their developer said this schedule_for needs shared access permission.

so after removing request to create meeting become like this.

 settings = {
        'enable': True,
        'host_video': True,
        'cn_meeting': True,
        'in_meeting': True,
        'join_before_host': True,
        'mute_upon_entry': False,
        'registrants_confirmation_email': False,
        'waiting_room': False,
        'watermark': False,
        'registrants_email_notification': True,
        'use_pmi': True,
        'rooms': None
    }

    meeting = {
        'topic': topic,
        'type': type,
        'start_time': start_time,
        'schedule_for': email,
        'duration': duration,
        'timezone': timezone,
        'password': password,
        'agenda': agenda,
        'settings': settings,
    }

now after removing it, its working fine for us now.

2 Likes

Thanks @jovy . That did the trick. Thanks a lot and unblocked us.

2 Likes

@jovy,
Thanks for sharing your insight @jovy! We appreciate you and all of your contributions to the Zoom Developer Forum.

1 Like