POST 403 {"code":403,"message":"Authenticated user has not permitted access to the targeted resource."}

I am facing an issue when trying to create meeting with Zoom API
POST 403 {“code”:403,“message”:“Authenticated user has not permitted access to the targeted resource.”}

I already have permission for “meetings:write”.

But, the same API works if user has allowed “Shared access permissions”

Question is: Why do we need shared access permission to create meetings for a single user who is owner of the account?

Same problem here, have you found a solution to create meeting without marking shared permission?

not yet… unfortunately

can someone in the community help… i tried many things but still couldnt figure out a way to create without shared permission enabled. This is a user level app and I have meetings read:write permission.

Still i get “no permitted access to the targeted resource”

Hi @prashanth1
I am really sorry we did not reply to your post earlier! I am happy to help troubleshoot this issue.
Could you please confirm if your app is published in the Marketplace? If so, could you please share the name of the application with me and take a look into this.

Hi @elisa.zoom ,
Thank you for responding. Sorry for getting back late. We are really stuck with this issue and not able to roll out our zoom integration.

Our app “Leadmonk” is in functional review currently and its stuck in that.

We did a straight forward zoom integration using oauth. But for creating a meeting, I keep getting the error
POST 403 {“code”:403,“message”:“Authenticated user has not permitted access to the targeted resource.”}

but GET works fine.

App has “meetings:write” permission.

The same call (POST works, if user provides “Shared access permission”. This is strange, as we are just making call to the account where user is the owner.

Any help to create meetings without “shared access permission” would be great.

Thank you

Hi @prashanth1
Do not worry about it…
This is an interesting case cause I have not seen this issue with other apps.
I tried creating a user-level app on my end and called both endpoints and it works just fine with Shared access permission and without it.

Have you heard anything back from the Functional review team?

Hi @elisa.zoom
Yes, most of the others apps I tested, don’t need “shared access”.

I submitted again for functional review, but I am assuming they will reject. I am unable to get it working without “shared access permission”.

Looks like few others are facing similar issue. for example. @bryandantas1 who replied in this thread.


So, not sure how where the issue is or how to proceed.

any guidance will help.

Thank you,

Thanks for sharing more details with me @prashanth1
I will go ahead and reach out to the Marketplace about this issue.

@elisa.zoom the solution posted here by @jovy did the trick.

Hey @prashanth1
Thanks for sharing this with me.
I did not know about this issue, so I appreciate you sharing this with me and the community!