Getting Joining timeout issue in 1.9.0

We have updated the zoom web sdk from 1.8.5 to 1.9.0. In that we are getting the issue Joining Timeout issue. I am not sure whether the issue with zoom SDK or in our integration.

Which Client Web SDK version?


Device (please complete the following information):

  • OS: Windows 10
  • Browser: Chrome

Additional context
Herewith i have attached the js i am using
[’$scope’, ‘$stateParams’,‘Principal’,’$rootScope’,
function ($scope, $stateParams,Principal,$rootScope ) {
Principal.identity().then(function (account) {
$scope.account = account;
$scope.isAuthenticated = Principal.isAuthenticated;

    $scope.Principal = Principal;
    Principal.hasAuthority('ROLE_ADMIN').then(function (result) {
        $scope.isAdmin = result;
    Principal.hasAuthority('ROLE_MANAGER').then(function (result) {
        $scope.isManager = result;

$rootScope.isJoinMeeting = true;
  $scope.API_KEY = "<api_key>";
  $scope.API_SECRET = "<api_secret>";
  var testTool = window.testTool;

 $scope.liveStream =  function () {	
	 if ($event) {
	 alert("Live Stream");	 
 $scope.zoomJoinMeeting =  function () {	

      var meetingConfig = {
    		  mn: $stateParams.meetingId,
    	      name: $scope.account.firstName+" "+$scope.account.lastName,
    	      pwd: "",
    	      role: 1,
    	      email: $,
    	      lang: "en-US",
    	      signature: "",
    	      china: 0
	     var signature = ZoomMtg.generateSignature({
	         meetingNumber: $stateParams.meetingId,
	         apiKey: $scope.API_KEY,
	         apiSecret: $scope.API_SECRET,
	         role: 1,
	        success: function (res) {			
	           meetingConfig.signature = res.result;
	           meetingConfig.apiKey = $scope.API_KEY;        	        
 	    		leaveUrl: "",
  	    		isSupportAV: true,
  	    		isSupportChat: true, //optional,
  	    		isSupportQA: true, //optional,
  	    		isSupportCC: true, //optional,
  	    		screenShare: true, //optional,
  	    		videoHeader: false, 
  	    	success: function () {
  	              signature: meetingConfig.signature,
  	              apiKey: meetingConfig.apiKey,
  	              passWord: $stateParams.password,
  	              success: function (res) {
  	                console.log("join meeting success");
  	                console.log("get attendeelist");
  	                  success: function (res) {
  	                    console.log("success getCurrentUser", res.result.currentUser);
  	              error: function (res) {
  	          error: function (res) {

function addScript() {
  var s2 = document.createElement( 'script' ); "zoom_s2";
  var src2 = "";
  s2.setAttribute( 'src', src2 );
  document.body.appendChild( s2 );
  var s3 = document.createElement( 'script' ); "zoom_s3";
  var src3 = "";
  s3.setAttribute( 'src', src3 );
  document.body.appendChild( s3 );
  var s4 = document.createElement( 'script' ); "zoom_s4";
  var src4 = "";
  s4.setAttribute( 'src', src4 );
  document.body.appendChild( s4 );
  var s5 = document.createElement( 'script' ); "zoom_s5";
  var src5 = "";
  s5.setAttribute( 'src', src5 );
  document.body.appendChild( s5 );

  var s7 = document.createElement( 'script' ); "zoom_s7";
  var src7 = ""
  s7.setAttribute( 'src', src7 );
  document.body.appendChild( s7 );
  var s8 = document.createElement( 'script' ); "zoom_s8";
  var src8 = ""
  s8.setAttribute( 'src', src8 );
  document.body.appendChild( s8 );
  var s9 = document.createElement( 'script' ); "zoom_s9";
  var src9 = "tool.js"
  s9.setAttribute( 'src', src9 );
  document.body.appendChild( s9 );
  var s10 = document.createElement( 'script' ); "zoom_s10";
  var src10 = "vconsole.min.js"
  s10.setAttribute( 'src', src10 );
  document.body.appendChild( s10 );

$scope.onLoad =  function () {	
       console.log("THIS IS");
   }, 2000);



Hey @vishnupriya,

Thank you for reaching out to the Zoom Developer Forum. First, you may want to compare your implementation with our Sample Angular App to make sure that everything is set up correctly. You can also use that app to test with your API Key/Secret and meeting to make sure that you are using the correct details.

If that doesn’t help, please provide any errors that you’re seeing in the browser console as well as the signature that you’re using when you encounter this issue.


Hi @MaxM ,

Herewith attached the console log. Actually i can able to get signature and init the zoom successfully. But the join meeting is not working fine not getting any response or error on join meeting. Only with the error popup on screen not on console.

I have just started from the scratch using angular js only.

1 Like

Hey @vishnupriya,

On thing I noticed about your code sample is that you’re calling ZoomMtg, indicating that you are using NPM for the package, but also importing resources from the CDN in your addScript() function. I think there are two separate versions of the dependencies being imported.

Here are some steps I would take to see if they help with the issue:

  1. Try moving the preLoadWasm() and prepareJssdk() functions to the top of the file, similar to how our sample app is set up:
  1. Test removing the addScript() function to see if importing the ZoomMtg package itself will work.

We can see that in the sample app, we don’t import any scripts via the CDN

  1. You may want to configure your angular.json file to match what we have in the sample app to ensure all the right dependencies are imported and available in the application:

Let me know if that helps! :slightly_smiling_face:


Actually max we are using angular js. So we used angular js for integration in that init worked but join meeting shows the same error with popup. But i have tried with Angular latest version with your sample app but shows the same issue is there with that as well

Hey @vishnupriya,

Thank you for following up and for testing with the sample app. Are you able to share the signature that you’re using when you see this error? I’ll investigate further using that.


Shall i share the signature here in forum? Is there any security violation when we share the signature here?

Hey @vishnupriya ,

You can share it privately to :slight_smile: Please make sure to include a link to this thread.


1 Like

Hey @vishnupriya,

Thank you for submitting a ticket.

For some reason, I’m not seeing a ticket created from that email but I see that Gus has had you CC my personal email so I was able to review the signature. From what I can see, the Meeting ID that you’re using doesn’t exist.

Please double check that meeting ID to make sure it matches a scheduled meeting on your account.

I hope that helps!


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.