Getting the ARR files into my own project

I’m pretty sure this question has been asked here a few times, but i can’t seem to find it.
I’m trying to implement zoom in my application and I’m following this guide >

-I’ve opened a folder called libs,
-put the 2 folders inside (commonlib and mobilertc) (also in the screenshot in the guide u have other files other these 2 folders)
-went to project structure (which looks different then the screenshot in the guide after the android update)
-pressed on modules > + icon > import .JAR/.AAR Package
-selected my commonlib.arr file
(basically did the same for the mobiletrc.arr file)

  • i DO see them under modules but all their settings are empty that’s the first thing
    -then i see them in the dependencies folder but i didn’t quit understand what i need to do then also

can u explain to me what i’m doing wrong or how to fix it ?

Which version?


Additional context
i’m using android studio after the latest update*
version 3.4.1

Hi shay3112,

Thanks for using Zoom SDK. Yes, I agreed that the Android Studio has changed a little bit so the current version’s options are a little different from those shown in the doc now.

I do not have the same AS version as you do, I am using the Android Studio 3.6.3 and hope the following could be helpful for you(It seems like AS provides an easier way to import library now)

  1. After creating a project, go to File> New > Import Module
  2. In the Source directory, press the “folder” icon and navigate to the folder that has the aar libraries. You only need to select on the folder, not the aar file itself.
  3. Then AS will add this module into the project and you will see it in the file structure.
  4. Then go to your app’s build.gradle file, add the following dependencies:
    implementation 'androidx.multidex:multidex:2.0.0'
    implementation 'androidx.recyclerview:recyclerview:1.0.0'
    implementation 'androidx.appcompat:appcompat:1.0.0'
    implementation 'androidx.constraintlayout:constraintlayout:1.1.3'
    implementation ''
    implementation project(':commonlib')
    implementation project(':mobilertc')

Then sync the gradle file.

Then you should be able to use SDK interfaces in your project. Hope this helps. Thanks!

build failed due to
Could not resolve all artifacts for configuration ‘:app:releaseCompileClasspath’.

Could not find :commonlib:.
Required by:
project :app
Could not find :mobilertc:.
Required by:
project :app

can u please help me to solve this issue

Hi @srikarkonda98,

Please refer to my answer to your question here: Failed to resolve: :mobilertc: