Not able to import zoom sdk modules into app

Description
I am following zoom’s official SDK documentation to create my zoom meeting app
… But a problem that I am getting stuck at is that I am not able to import zoom’s SDK modules commonlib and mobilterc to the app in android studio. The final and next buttons always become disabled.

Which Android Meeting SDK version?
v5.5.1.1319

To Reproduce(If applicable)
Steps to reproduce the behaviour:

  1. Go to ‘File’
  2. Click on ‘new’
  3. Click on ‘import module’
  4. Navigate the ‘zoom SDK file’
  5. See the error of not being able to click finish

Screenshots

Smartphone (please complete the following information):

  • Device: Nexus 5X API 25
  • OS: Nougat Android 7.1

Additional context
Link to the documentation I am following:- https://marketplace.zoom.us/docs/sdk/native-sdks/android/getting-started/install-sdkemphasized text

Hi @RGCoder, thanks for using the dev forum.

The reason you are unable to import on this screen is because you have selected the commonlib directory instead of the commonlib.aar file contained in that path.

Thanks!

I did try it but as you can see an error popped up:-

For more info:-

Hi @RGCoder,

Thanks for providing those screenshots. It looks like the wrong option may have been selection in the previous window. When you open the import module window via Right click project -> New -> Module, you should select the Import .JAR/.AAR Package option as pictured below.

Screen Shot 2021-08-23 at 4.49.55 PM

Thanks!

So I clicked the New Module option and the following screen pops up…

What next…

Hi @RGCoder,

Strange, that is not the same menu I am seeing. Are you perhaps on an older version of Android studio? Does that same menu come up both when you right-click the root folder in your project and when you go through the File dropdown menu? If you’re still having issues with this approach, there is an alternative method to add the SDK described here.

Thanks!

The android studio used is
Android Studio Arctic Fox | 2020.3.1 Patch 1
Build #AI-203.7717.56.2031.7621141, built on August 7, 2021
Runtime version: 11.0.10+0-b96-7281165 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 11.5.2

It happens the same to me. I cannot even run any zoom integration app dowloaded from Github it does not recognize the commonlib and webrtc packages.

I run this under M1 Apple Mac

@mbeascoa
So I found a rough solution to the problem…

  1. Copy and Paste both the Commonlib and Mobilertc modules to the project directory
  2. Go to Project Structure > Dependencies > Click + > JAR/AAR Dependencies and give the path to both the modules which are there.
  3. It will automatically add the modules as dependencies.

Hi @mbeascoa, thanks for using the dev forum.

Have you tried the solutions mentioned previously in this thread? Please let me know which specific approaches have not worked for you and I will be happy to help.

Thanks!

Thanks for the tip. I could implement that way the Commonlib and Mobilertc modules to the project. Then when running the example, I needed to increse the minimim SDK fro 16 to 21 and then happens that error…
By the end of July I was able to make it run, but now upgrading to Android Artic I am facing many problems.

Hi @mbeascoa,

In that error code, there is actually a suggestion which should resolve your issue. :slightly_smiling_face:

Please let me know if you are running into any issues with the SDK and I will be happy to help.

Thanks!