Granular Scopes doesn't Work

Hello, I created a new server to server application and added the scopes as in the link below, and when I use the API, I get the scope missing error.
Link: ‘Integrations - Granular scopes
Is it necessary to wait for additional authorization or a certain period of time for these new granular scopes to work?
Is there anyone getting the same error as me?

Hi @bilgin_yazar ,

Yes not all granular scopes available for new apps at this time, but a rollout is pending. We will share more info shortly.

Thank you for your patience.

Estimated when the update will come customers are waiting

Updates will be shared via developer announcement and changelog :slight_smile:

Hi again.
I think it has been updated and granular scopes are working now.
However, I could not find the scope I used below among the granular scopes.
My request:

Error= [Invalid access token, does not contain scopes:[role:read:list_members, role:read:list_members:admin]

API from which I pull Zoom Users. How can I fix this

Hi @bilgin_yazar ,

Roles endpoints are a part of the Zoom Account API. As you can see here, the granular scopes for Roles is not yet available.

Is there any way I can use it anymore ?

Hi @bilgin_yazar , you can use it on a legacy app that has the older scopes, but will have to wait for the granular scopes to be released for new apps to use them.

Is it possible to opt-out of the new granular scopes for now until all the scopes are supported that we need?

Hi @kdawgwilk-elephant , unfortunately there’s not an option to opt out, but I’d keep track of the endpoints that you need granular scopes for as its being rolled out.

Hello @gianni.zoom
All our legacy apps for zoom which were using JWT were deleted by Zoom and now we can only create a new s2s OAuth app which looks does not have that role:read:list_roles scope.
Could you advice please, how can we create a new s2s app with role scope.