Having a hard time setting up Zoom Electron SDK

I am trying to follow the steps listed in the documentation Download and install but I am not able to get past step 5 (build_nodeaddon_mac.sh).

Which Electron Meeting SDK version?

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. I already have node installed so I started with step 2 and completed step 2-4 without any issues.

  2. Downloaded protobuf source code version 3.19.4

  3. Renamed src to protobuf_src and added it under lib/node_add_on

  4. Ran sh build_nodeaddon_mac.sh and saw a bunch of errors. Then I followed the steps to “Build with different protobuf version”. I installed protoc-3.19.4-osx-x86_64.zip and added the bin directory with the protoc.exe to my system’s path.

  5. But when I ran this command: protoc.exe —js_out=import_style=common.js,binary:. lib/electron_sdk_proto
    it returns, protoc.exe command not found

I was able to do which protoc and it returns the correct path of where the exe file is.

I also tried the command protoc —js_out=import_style=common.js,binary:. lib/electron_sdk_proto
but it returns missing output directives

Device (please complete the following information):

  • Device: [Apple MacBook Pro (16-inch)]
  • OS: [ macOS Big Sur 11.6.1 ]

Additional context
node version: v14.16.1

What am I missing here…? Is it a versioning issue? Are the commands correct? Is this electron version still supported?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.