Hi. When I use the Zoom Meeting SDK in Safari, I get a warning message that Safari does not support Computer Audio

Hi. When I use the Zoom Meeting SDK in Safari, I get a warning message that Safari does not support Computer Audio.

The browser does not support the use of the computer’s audio device.
To use Zoom, install the latest version of standard browser such as Chrome or Firefox.

Which Web Meeting SDK version?
Im using Web Meeting SDK version 2.6.0

Meeting SDK Code Snippets
Follow the following message " (3) Safari Audio is supported if your site uses credentialless headers or is not cross origin isolated. See Web SDK Gallery View for implementation instructions."
I have enabled SharedArrayBuffer make my sites credentialless headers. It works on Chrome and Edge but not on Safari.

I have attached the screenshot below.

Device (please complete the following information):

  • Device: [Macbook Pro]
  • OS: [macOS 11]
  • Browser: [Safari]
  • Browser Version [16.0/15.4]

Additional context
In its current state, even if you set disableJoinAudio to true and audioPanelAlwaysOpen to false at init, it still relates to the above Audio.
So is there anyway I can hide the warning message and enable SharedArrayBuffer on Safari?

Thanks and Best regards,

1 Like

you have do modify your server programming

if Safari calls the Server: Server has to send the meeting page html with normal headers

for Chrome: the Server has to send the page with credentialless headers or Cross-Origin Isolation headers

for Firefox*: the Server has to send the page with Cross-Origin Isolation headers


*from Firefox 105 the Meeting Web SDK (2.7.0) seems to support Gallery View (don’t work with credentialless headers, they are not supported)

1 Like

Thanks for your suggestion.
I have tried Safari on version 15.4, I disabled all CORS, COEP, COOP headers but sadly it’s not working.
Have you tried on Safari?

no - I am on Windows

what happens if you enter the meeting in Safari direct on zoom.us (without SDK)

copy the Invite Link of your meeting and replace /j/ with /wc/join/

or click the original link and cancel, then “Join from Your Browser”

1 Like

Thanks mate, I tried it. It’s also showing the same warning message. So is that what you are thinking about? I think Zoom haven’t supported Safari yet, right?

have you checked the permissions for the microphone?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.