Hide "Meeting in progress" notification not working

Description
“Meeting in progress” is currently displayed in notification panel, even though setting to hide it is set

Which version?
v4.6.15086.0209

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Connect call with isCustomizedMeetingUIEnabled set to true and disableShowMeetingNotification(true)
  2. “Meeting in progress” is still shown

Screenshots

Smartphone (please complete the following information):

  • Device: [Galaxy Note 9, Galaxy A50]
  • Version [Android 9.0, 10.0]

Hi reesetrtw,

Thanks for using Zoom SDK. Yes, this interface has some constraints as described in the API reference:

I will forward this to the engineering team and see if there is any way to optimize it.

Thanks!

This allows anyone to enter the zoom call without custom UI enabled when clicked, offering a backdoor to hidden features by participants. This is a huge issue for our use case and users.

Optimally, you offer the option to provide a custom ongoing notification(builder).
Next best would be ability to customize text, icon, and intent action.

1 Like

Hi,

Thanks for the reply. Based on the Android P’s change log(https://developer.android.com/about/versions/pie/android-9.0-changes-all), starting from Android P, it requires the app to have system notification while in the background, otherwise the meeting will not have sound. I have forwarded your feature request of customizing the content in the notification to the engineering team, and we will evaluate the possibility of adding this feature in the future release. Please follow our Github repo for any updates.

Thanks!

hello sir ,

So if Possible to customize notification on notification bar, or Change The logo of Zoom .

Hi aadil9265711,

Thanks for using Zoom SDK. I see you have another post regarding this question, please see my reply here: Notification Remove

Thanks!