How to change language for transcription for cloud recording?

Description
Error

  • Want to enable English transcription.
  • Setting for transcription of English cloud recording, I have already done presetting for this from the manual from the support page
  • using enterprise account(not mine, my client have)
  • But there is no transcript data in the file .

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT

Which Endpoint/s?

How To Reproduce (If applicable)
Add any other context about the problem here.

Now, using Zoom in Japanese usually.
I read that the auto transcript function is for only English.
NOW I WANT TO USE THIS FUNCTION IN ENGLISH.
My question is how can I change transcription language mode? Do we have to care about Account-Group-User all to change to some setting?

Hey @Kotaro,

Thank you for reaching out to the Zoom Developer Forum. Just to make sure I understand, are you looking to enable audio transcription for cloud recordings via the API?

If so, try using the recording_audio_transcript property for the Update Account Settings or the Update User Settings API.

image

I hope that helps! Let me know if that answers your question.

Thanks,
Max

1 Like

Hi, Max,

Thank you for your quick reply.
I understand that the transcript can be configured with this boolean setting value.

I’m sorry, but I have a further question if you could follow up.
As I understand it, the zoom transcript only supports English, not other languages.
What setting determines this which language?

Thanks

Hey @Kotaro,

Are you able to elaborate a bit more on your question? Due to the fact that only English audio transcription is supported, we don’t have a method to change the language.

Can you send a screenshot of what you are referring to?

Thanks,
Max

Hi Max

Thank you for following up.

Now, we are already using a meeting recording api to get an audio transcript file to identify the timing of each participant’s speech.
What I want to do is to get english transcript file adding existing speech timing information.
Here, I attached some of the sample file I’m usually handling.
Based on my understanding, I supposed to get audio transcript text inside but I couldn’t find any.

I thought this is because of language differentiation but if not, what else do I have to set? note:I already set audio transcript setting to generate this file

Hope this email answers you properly but if you need additional information, please let me know.

Best

Kotaro

2021年4月17日(土) 4:40 Max M. via Zoom Developer Forum <zoomdeveloper@discoursemail.com>:

Hey @Kotaro,

Thank you for clarifying. Just to make sure I understand the issue, were you speaking English in the meeting or something else? The audio transcript will only work when people speak English in the meeting and it is not able to translate.

Let me know if that helps.

Thanks,
Max

Hi Max

thank you for your continuous support.

Thank you for clarifying. Just to make sure I understand the issue, were you speaking English in the meeting or something else? The audio transcript will only work when people speak English in the meeting and it is not able to translate.

Yes. I know that translate function is not an option here.
My question is how can you detect participants are speaking English? Is Zoom automatically detect which language participants are speaking or checking language settings?
Here are three patterns in our use cases,

  1. English only
  2. Mix English and Japanese (like for educational courses, participants are speaking both)
  3. Japanese only

Best

Kotaro

2021年4月20日(火) 6:55 Max M. via Zoom Developer Forum <zoomdeveloper@discoursemail.com>:

Hey @Kotaro,

Thank you for the update!

Got it, I understand the question now. That’s a good question too! I’ve reached out to an internal resource to confirm how the transcription service determine the language.

I’ll update you here as soon as I have more information.

Thanks,
Max

Hi Max,

Thanks a lot.
waiting for your information.

Best
Kotaro

2021年4月23日(金) 6:41 Max M. via Zoom Developer Forum <zoomdeveloper@discoursemail.com>:

Hey @Kotaro,

I spoke with my team about this but we weren’t able to confirm the behavior. I’ve since reached out to our engineering team and will get back to you when I have more information. (ZOOM-268746)

Thanks,
Max

Hi Max

Thank you for your support.
Waiting for an answer from your engineering team.

Kotaro

2021年4月24日(土) 5:51 Max M. via Zoom Developer Forum <zoomdeveloper@discoursemail.com>:

Hey @Kotaro,

I don’t have an update from them just yet but I’ll let you know as soon as I do.

Thanks,
Max