Setting Default Language for Zoom Cloud Recording Transcriptions via API

API Endpoint(s) and/or Zoom API Event(s)
Working with: Get meeting recordings ( /meetings/{meetingId}/recordings)

I have a question regarding the transcription language in Zoom’s cloud recordings. When using the above API to retrieve transcriptions of recorded meetings, I noticed that the downloaded file with file_type as TRANSCRIPT is in English.

Upon checking the Zoom admin interface, it seems that the transcriptions are defaulted to English, as indicated by the red box in my attachment.
I was able to change the transcription language to Japanese on the interface and re-download the transcript in Japanese.

My question is: Is there a way to set the default transcription language to Japanese, so that the API returns Japanese transcriptions by default?

No specific error, but the issue is the default language setting for transcriptions.

How To Reproduce
Steps to reproduce the current behavior:

  1. After a meeting, use the API endpoint /meetings/{meetingId}/recordings to request the recordings and transcripts.
  2. Authentication is done via [mention your authentication method, e.g., JWT/OAuth].
  3. The downloaded transcript file is in English, despite needing it in Japanese.
1 Like

Hi @ShiKa
I am not aware if there is a way to set the transcription to another language but I can do some testing on my end and will get back to you with my findings.

Hi @ShiKa
Have you tried changing the settings to only allow Automated Captions in Japanese?
This could be a workaround to generate them in Japanese only

Hello, @elisa.zoom

I hope you don’t mind me adding to ShiKa’s question.

You suggested using automated captions for ShiKa’s issue. I’m interested in hearing more about this as users need to enable captions and some may not prefer them.

As ShiKa mentioned, we can change the language and download the transcription from the admin panel. But, is there a way to download transcriptions in non-English languages via the API?

I also need to set the default language for the automatic transcriptions that are generated in cloud recordings. The original audio is always in Spanish, but the transcription interprets the audio as if it’s in English, and attempts to transcribe it into English. As you can imagine, the result is useless. By going into Cloud Recordings and changing the language of the VTT file, it generates the correct transcription in Spanish.

1 Like

Hi @elisa.zoom

What @isao and @ Dani have added is exactly what I wanted to ask.
The core issue for developers using the Zoom API is the ability to download transcriptions in non-English languages (especially Japanese for me) directly via the API, without manual adjustments.

The workaround involving changing automated caption settings isn’t ideal for all users.

This significantly impacts the usability of Zoom-generated transcriptions for apps integrating with Zoom API, particularly for global users conducting meetings in various languages.

Any guidance or planned updates from the Zoom team to address this would be highly appreciated.

1 Like


Hello, could you please provide any updates on this issue?