How to create the meeting of next day?


#1

I am not able to create meeting of next day using rest API. After create the meeting it is taking my current system time as start_time.

I am sending this model,

{“topic”:“Interview Video”,“type”:2,“start_time”:“2019-01-17 11:30:00”,“duration”:20,“timezone”:“Asia/Kolkata”,“password”:null,“agenda”:“Video Interview”,“recurrence”:null,“settings”:{“host_video”:true,“participant_video”:true,“cn_meeting”:false,“in_meeting”:true,“join_before_host”:false,“mute_upon_entry”:false,“watermark”:false,“use_pmi”:false,“approval_type”:0,“registration_type”:0,“audio”:“voip”,“auto_recording”:“local”,“enforce_login”:false,“enforce_login_domains”:null,“alternative_hosts”:null}}

And after create I am geeting this response,

{“uuid”:“hcOXjplpQCqcCTU1fGoT1w==”,“id”:481245424,“host_id”:“52hgnv7LQqaI3u7G4KT-Ww”,“topic”:“Interview Video”,“type”:2,“status”:“waiting”,“start_time”:“2019-01-15T05:38:04Z”,“duration”:20,“timezone”:“Asia/Kolkata”,“agenda”:“Video Interview”,“created_at”:“2019-01-15T05:38:04Z”,“start_url”:“https://zoom.us/s/481245424?zak=eyJhbGciOiJIUzI1NiJ9.eyJhdWQiOiJjbGllbnQiLCJ1aWQiOiI1MmhnbnY3TFFxYUkzdTdHNEtULVd3IiwiaXNzIjoid2ViIiwic3R5IjoxMDAsIndjZCI6ImF3MSIsImNsdCI6MCwic3RrIjoiYUIxRjdFMVdZSkJETGtXMnNtOXZEVFMyekI3Wm9SVnBReTBpekNoRU1KVS5CZ1VnTUZSa2VIQmFlVlJTVTFWckswUldjMmRJZEZSVlpGUlBVM0pXTTI4Mk9XNUFNR1F5T1RKbU1qSmtOMlZpTVRsaE1qRmxNRGc1TURReU5EaGlObU01WlRNd01UYzVabU5pTXpKbFpHVTJaRGd3TjJaaVl6RTROelF6Wm1FNE1XSmlaQUFNTTBOQ1FYVnZhVmxUTTNNOUFBTmhkekUiLCJleHAiOjE1NDc1Mzc4ODQsImlhdCI6MTU0NzUzMDY4NCwiYWlkIjoiZmJ4WTdVQnVUZk9LSUg0azFrMkVkdyIsImNpZCI6IiJ9.3r4R41pV3Pm3bhUYw2e6P3N9eDTaaZ0sBcqidaChhRg",“join_url”:“https://zoom.us/j/481245424”,“settings”:{“host_video”:true,“participant_video”:true,“cn_meeting”:false,“in_meeting”:true,“join_before_host”:false,“mute_upon_entry”:false,“watermark”:false,“use_pmi”:false,“approval_type”:2,“audio”:“voip”,“auto_recording”:“local”,“enforce_login”:false,“enforce_login_domains”:"",“alternative_hosts”:"",“close_registration”:false,“registrants_confirmation_email”:true,“waiting_room”:false,“global_dial_in_countries”:[“US”],“contact_name”:"Prakash Chandra”,“contact_email”:“itinfra@globalhunt.in”}}

How can we fix this ?


#2

Hi @prakash,

Please refer to https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingcreate

When using a format like “yyyy-MM-dd’T’HH:mm:ss’Z’”, always use GMT time. When using a format like “yyyy-MM-dd’T’HH:mm:ss”, you should use local time and you will need to specify the time zone. Only used for scheduled meetings and recurring meetings with fixed time.

Make sure to include the “T” when you’re using local format.