Rest API create a meeting API issue

Post API https://api.zoom.us/v2/users/{user_id}/meetings

request body
{
“created_at”: “2019-10-03T13:10:00”,
“duration”: 60,
“settings”: {
“approval_type”: 2,
“audio”: “both”,
“auto_recording”: “local”,
“close_registration”: false,
“cn_meeting”: false,
“enforce_login”: false,
“host_video”: false,
“in_meeting”: false,
“join_before_host”: true,
“mute_upon_entry”: false,
“participant_video”: false,
“registrants_confirmation_email”: true,
“use_pmi”: false,
“waiting_room”: false,
“watermark”: false
},
“start_time”: “2019-10-03T13:10:00”,
“timezone”: “Asia/Calcutta”,
“topic”: “Lattice API Test”,
“type”: 1
}

response

{
“page_count”: 1,
“page_number”: 1,
“page_size”: 30,
“total_records”: 1,
“meetings”: [
{
“uuid”: “hBY/2lAWT5mRcESE3LY5Wg==”,
“id”: 339700797,
“host_id”: “_SZM7AwTSQ2HqKfnxfcDvw”,
“topic”: “My Meeting”,
“type”: 2,
“start_time”: “2019-09-27T06:30:00Z”,
“duration”: 60,
“timezone”: “Asia/Calcutta”,
“created_at”: “2019-09-27T05:48:12Z”,
“join_url”: “https://zoom.us/j/339700797
}
]
}

Issue
in response below value is not updated
type, topic, created_at, start_time

Hi @dev3,
Welcome to the Zoom Developer Community.

For the Create Meeting API, you do not have to pass the created_at parameter. This field belongs to the response, and the value denotes the date and time at which this meeting was created. Irrespective of it, the parameter would be ignored if you add this within the request.

Looking at the request and the response, it seems that the response belongs to some other request, as the “start_time” and “created_at” predates the current date. Can you please recheck the response within the API call log, whether it belongs to the same request?

Thanks

Hi @Ojus,
API call log
{

“endpoint”: “https://api.zoom.us/v2/users/_SZM7AwTSQ2HqKfnxfcDvw/meetings”,

“response_headers”: [

“Set-Cookie: cred=EF1B4AEFAA425658CA1B8E7A6B7437CA; Path=/; Secure; HttpOnly”

],

“date_time”: “2019-10-04 09:45:36”,

“method”: “GET”,

“request_body”: “{“duration”:60,“settings”:{“approval_type”:2,“audio”:“both”,“auto_recording”:“local”,“close_registration”:false,“cn_meeting”:false,“enforce_login”:false,“host_video”:false,“in_meeting”:false,“join_before_host”:true,“mute_upon_entry”:false,“participant_video”:false,“registrants_confirmation_email”:true,“use_pmi”:false,“waiting_room”:false,“watermark”:false},“start_time”:“2019-10-03T13:10:00”,“timezone”:“Asia/Calcutta”,“topic”:“LatticeAPITest”,“type”:1}”,

“response”: {

“page_count”: 1,

“page_number”: 1,

“page_size”: 30,

“total_records”: 1,

“meetings”: [

{

“uuid”: “hBY/2lAWT5mRcESE3LY5Wg==”,

“id”: 339700797,

“host_id”: “_SZM7AwTSQ2HqKfnxfcDvw”,

“topic”: “My Meeting”,

“type”: 2,

“start_time”: “2019-09-27T06:30:00Z”,

“duration”: 60,

“timezone”: “Asia/Calcutta”,

“created_at”: “2019-09-27T05:48:12Z”,

“join_url”: “https://zoom.us/j/339700797

}

]

},

“request_headers”: [

“accept-encoding: gzip, deflate”,

“accept: /”,

“authorization: ******”,

“connection: close”,

“content-type: application/json”,

“user-agent: PostmanRuntime/7.6.0”

],

“request_params”: [

],

“http_status”: “200”

}

Hi @dev3,

Looks like you were using a GET instead of a POST which is why you received a 200 instead of a 201 and the payload looks different. Please ensure that you’re using a POST when creating meetings.

Let us know if this helps.

Thanks