How to hide the error prompts in customized UI?

Description
When use customized UI, encountered cases that the error prompts like below were shown
prompt_1
prompt_2

Anyway to hide them?

Which Android Meeting SDK version?
v5.5.1.1319, v5.7.1.1267

Thanks

Hi @kevinxiao, thanks for the post.

Are you able to reproduce this in the sample app? I am not seeing either of these dialogs appear in the sample app under the conditions that would normally trigger them. If you can, please provide steps to reproduce so that we can investigate further.

Thanks!

hello @jon.lieblich

Please try below steps:

  1. schedule a meeting via API POST /users/{userId}/meetings
  2. in sample app, update MyMeetingActivity#onMeetingLeaveComplete, comment out/remove below codes to keep the activity
        if (!mMeetingFailed)
            finish();
  1. launch the sample app, enable Customized UI in Settings
  2. tap API User, input values then tap Start this Meeting
  3. after joined the meeting in app,
    call API PUT /meetings/{meetingId}/status to end the meeting
    call API DELETE /meetings/{meetingId} to delete the meeting

You may see the “Can’t connet to our service, please check…” in sampe app during step 5

Additional, I found in above case, the value passed to onMeetingLeaveComplete is 7 when using SDK v5.7.1,
and it is 6 when using SDK v5.2.42043.1112

Thanks

Hi @kevinxiao,

Thanks for providing the steps to reproduce. It does appear that there is something going on with dialogs displaying incorrectly while custom UI mode is enabled. We will investigate this and let you know as soon as we have any updates.

In the meantime, it seems that the no_meeting_end_message field being set to true does prevent this dialog from appearing in the scenarios I tested. This could serve as a workaround as we are looking into this on our end.

Thanks!

hello @jon.lieblich

tried several times and seems it works, thank you.

additional question: what does no_meeting_error_message work for? couldn’t find detail description in SDK reference…

Thanks.

Hi @kevinxiao,

Glad to hear that’s working! I do want to emphasize that this should not be necessary when using custom UI mode and we are working on a fix so that it is only required when using the default UI.

additional question: what does no_meeting_error_message work for? couldn’t find detail description in SDK reference…

This would hide the error dialog that appears in some scenarios. For example, if you were suddenly disconnected from a meeting due to lack of network connectivity, enabling this would result in that dialog not being shown. Since you are using a custom meeting UI, the options available through MeetingOptions usually do not apply though.

Thanks!

hello @jon.lieblich

verified the fix in v5.7.1.1268, thx

Glad to hear it’s working now, thanks for confirming!