How to hide user default avatar on joining meeting

How can I hide the default avatar pic of user while joining the meeting.
I don’t want to go with Custom UI, as I want to use gallery view feature of zoom sdk & that is fine with default UI…


see the default user icon (avatar) image while running meeting… want to hide this…

Hi @nilefire103, thanks for using the dev forum.

Unfortunately, there is no way for a user to hide their own video through the default UI in this scenario. A custom meeting UI would be required. That being said, you can absolutely still implement your own gallery view when using a custom meeting UI. :slightly_smiling_face:

Thanks!

Can you please provide me a sample code for the same so that I can check how it can be done ? I just want to show multiple videos at once using gallery view & all its functionality that is now available with default UI. All functionality means - swipe, pin video, double tap etc…

Hi @nilefire103,

We don’t have a sample implementation of exactly what you are asking for, but the sample app included with the SDK has a custom UI implementation that could be a useful starting point. Since you are solely responsible for the appearance and behavior of your app’s UI when custom UI mode is enabled, any parts of that implementation which do not directly interact with our SDK are going to be outside of the scope of what we can assist with.

Let me know if you have any questions on how to utilize the SDK for specific pieces of behavior and I’ll be happy to help. :slightly_smiling_face:

Thanks!

I tried to run the sample code you have given with Custom UI setting checked, but when I check this option & click join meeting, nothing happens… attached is the screenshot for your reference…

Hi @nilefire103,

When you try to join a meeting, are you certain that you have provided a valid meeting number? If so, please provide a screen recording of the behavior you are experiencing so that we may better assist.

Thanks!

Ok, please check the video uploaded on the link mentioned below, with customized meeting UI using your sample app, its not joining, however its joining with default meeting UI.
Note: i have hidden the Meeting ID while creating the video, its being passed internally…

http://aryan123-001-site1.ctempurl.com/zoom_issue.mp4

Hi @nilefire103,

Thanks for providing that video. That certainly seems strange. Can you check what the return value of the joinMeetingWithParams call is in the sample app when this occurs? It can be found on line 42 of JoinMeetingHelper. Also, which version of the SDK are you using?

Thanks!

Code of file (not changed anything): 
mobilertc-android-studio\sample\src\main\java\us\zoom\sdksample\ui\InitAuthSDKActivity.java

public void onClickJoin(View view) {
        if(!mZoomSDK.isInitialized())
        {
            Toast.makeText(this,"Init SDK First",Toast.LENGTH_SHORT).show();
            InitAuthSDKHelper.getInstance().initSDK(this, this);
            return;
        }

        if (ZoomSDK.getInstance().getMeetingSettingsHelper().isCustomizedMeetingUIEnabled()) {
            ZoomSDK.getInstance().getSmsService().enableZoomAuthRealNameMeetingUIShown(false);
        } else {
            ZoomSDK.getInstance().getSmsService().enableZoomAuthRealNameMeetingUIShown(true);
        }
        String number = numberEdit.getText().toString();
        String name = nameEdit.getText().toString();

        JoinMeetingParams params = new JoinMeetingParams();
        params.meetingNo = number;
        params.displayName = name;
        JoinMeetingOptions options=new JoinMeetingOptions();
        int result = ZoomSDK.getInstance().getMeetingService().joinMeetingWithParams(this, params,ZoomMeetingUISettingHelper.getJoinMeetingOptions());
       Log.d("join result", result + "");   **//result is 0 in both cases // customized UI or without it**
    }


Code of file (changed):
mobilertc-android-studio\sample\src\main\java\us\zoom\sdksample\initsdk\InitAuthSDKHelper.java

public void initSDK(Context context, InitAuthSDKCallback callback) {
        if (!mZoomSDK.isInitialized()) {
            mInitAuthSDKCallback = callback;

            ZoomSDKInitParams initParams = new ZoomSDKInitParams();
            **//commented below line**
            **//initParams.jwtToken = SDK_JWTTOKEN;**
            initParams.enableLog = true;
            initParams.enableGenerateDump = true;
            initParams.logSize = 5;
            initParams.domain = AuthConstants.WEB_DOMAIN;
            **//added below 2 lines**
            **initParams.appKey = "My SDK Key";**
            **initParams.appSecret = "My SDK Secret";**
            initParams.videoRawDataMemoryMode = ZoomSDKRawDataMemoryMode.ZoomSDKRawDataMemoryModeStack;
            mZoomSDK.initialize(context, this, initParams);
        }
    }

Hi @nilefire103,

Are you absolutely certain that you have not made any other changes? Can you try downloading a fresh copy of the sample app and running it again just to be sure? I have tried to reproduce this across multiple devices but have not been able to.

Thanks!