I just want to get the id and secret to use the reporting API, I don't need an actual app

I want to create an R language wrapper to the reporting API. The concept of creating an app (I’m following these instructions: Zoom Developer Docs) is overkill, but I have had to follow a similar process with other services.
[The Ideal would be just generating an api token and using that]

The documentation does not match what I’m seeing after getting through the Scopes step. The doc describes several other tabs, whereas I only have an ‘Activation’ tab. I believe this is similar to what’s called ‘Submit’.
When I click ‘Add’ I get an error in a new browser tab: 08.04.2022-09.19.41 . The redirect URL I chose was our company’s subdomain, hoping that it wouldn’t really matter because again conceptually this isn’t relevant to my purpose.

So now I’m stuck and I can’t get the app added and presumably won’t be able to authenticate. Do I need to go back and work with our IT to create a legitimate redirect url? Can I ignore this? Is it possible to completely avoid the Oauth app creation altogether?

Hi @ChrisU

Thanks for reaching out to the Zoom Developer Forum and welcome to our community, I am happy to help here!

Can you please make sure to add your Redirect URL for OAuth to your OAuth allow list and try again?
Not having your Redirect added to your Allow list, might be the issue why you are not able to authorize the app

I also wanted to add, have you looked into our Server-to-Server OAuth app?
Sound like you could benefit from this app type:

Here is a guide I wrote about this:

Best,
Elisa

Thanks, the Server to Server OAuth App was what we needed to do. IT enabled it for me and I went through the process but ran into a problem when activating. I press the blue button and nothing happens. I turned on the developer tools in Chrome and the click is registering and it says 403 error, Forbidden, No Permission.

IT double checked my role on the server to server app, I have view and edit. What is going on with it?

Hi @ChrisU
Sorry for the late reply.
Could you please make sure to have the Zoom for the Developer feature enabled for the role that your team has given you in order to use Server to Server Oauth app?

1 Like

Thanks that helped, IT did that and I was able to activate

Amazing! happy to hear that worked out @ChrisU