Invalid client_ID: (4,700)

New to calling API’s and thought I’d try to solve an issue we are having with providing accurate attendee list to users.

After creating the app and trying to add it, I continue to get Invalid client_ID: (4,700). I’m logged in with the only account that we use and still getting same error. I’ve tried using JWT and 0Auth

I’m trying to pull attendee list from zoom meeting to be able to reflect who all attended the meeting from different organizations.

Hi @KappaPsi1926
Thanks for reaching out to the Zoom Developer forum and welcome to our community!
Could you please share with me how are you generating your access token to call our endpoints?
Also, what endpoint are you trying to call?


Hi Elisa,

I generated them by building the app via market place. I also put the link from activation in the redirect based off what I kept seeing in videos and support site. And endpoint wise, I was trying the basic ones first from this link

Thanks @KappaPsi1926
If you are working with an OAuth app, please make sure that you are adding your redirect url to the Allow list

Also, here is a link to a guide on how to set up and use our Server to Server Oauth app with Postman:

Hope this helps,

Hi Elisa,

So I setup the Server to Server OAuth app but still getting invalid callback url. In market place, I wasn’t given the url to use. How do I get the correct callback url?

Hey @KappaPsi1926
you do not need to authorize the server to server oauth app, thats why you do not get a url to use.
You just make a post request to our oauth endpoint to get an access token

Ok, I’m still getting this when trying to post request to your oauth endpoint

"reason": "Invalid Client Id and Client Secret",
"error": "invalid_client"

For authorization I put OAuth 2.0, set variables for ID and Key I put the account ID from the app in the url as well

Can you please try to put Basic Auth and use Client ID as user name and Client Secret as password?

Your request should look like this

I changed to Basic Auth, set variables for user name and password that came from the app and send url exactly as you sent in the POST field and got same error

Finally was able to get access token. Went to GET, pasted the token and I’m getting this now

“code”: 4700,
“message”: "Invalid access token, does not contain scopes: [user:write:admin, user:read:admin, user:read, user:write]

hey @KappaPsi1926
So now that you were able to generate the token, make sure that you add the appropriate scopes so you can access the endpoints that you want.

So I didn’t see attendees listed under scope and what to make sure that those are received, do you know which scope needs to be added for this?

What endpoint are you trying to call?

Participants for past meeting.

Also, a meeting that I just had yesterday is not showing up when I search endpoint for /meetings