In Postman : { "code": 124, "message": "Invalid access token." }


#1

Hi, I tried to hit the get user service in postman but am getting error message as

{
“code”: 124,
“message”: “Invalid access token.”
}


#2

Hi Aadarsh, do you set the correct access_token value to your API request?


#3

Yes, I had generated the access token from the JWT


#4

@Aadarsh, so maybe your access_token is invalid. Can you please provide more details about your access token?


#5

I am using this to generate access token


#6

Did you put the api secret with no extra white space to the JWT?


#7

In JWT where?


#8

@Aadarsh, please refer to https://zoom.github.io/api/#authentication

Api secret should be put to “Signature” section.


#9

Gone through it but still have the same issue.
when I am putting my api secret key in the signature section it JWT gives error as Invalid Signature.


#10

@Aadarsh, just need to modify the “exp” value


#11

Working good but have issues with the create meeting api. Getting error as Invalid CORS request.

Getting this issue with the POST service. Working fine with the GET services.

 


#12

@Aadarsh, please refer to https://support.zoom.us/hc/en-us/community/posts/360000250663-Zoom-API-POST-sending-Invalid-CORS-request?page=1#community_comment_360000087426


#13

Added the Interceptor but after that I am getting some error like this: 

{
“code”: 300,
“message”: “Invalid enforce_login_domains, please separate multiple domains by semicolon”
}

 


#14

@Aadarsh, please set correct “enforce_login_domains” value or remove this parameter.


#15

For Origin what should be the value?? For now I am using https://developer.zoom.us as the origin. This origin name was mentioned in the community forum that you have mentioned in the last post 

 


#16

@Aadarshhttps://developer.zoom.us is correct.

The response error message means that you should set correct “enforce_login_domain” value or remove this parameter.


#17

I removed the enforce login domain parameter and it is working fine. but what should be the correct enforce_login_domain?