{"code":124,"message":"Invalid access token."} - Postman when calling List users with JWT

Description
I am following the API documentation to test API using Postman. I have called List User API after entering token generated using jwt.io.

Error
{“code”:124,“message”:“Invalid access token.”}

I am using JWT

Hey @gupta.gaurabh, thanks for posting and using Zoom!

How are you passing in the JWT Token in postman?

Thanks,
Tommy

Thanks for the reply @tommy! I have entered the token generated into the collection

Hey @gupta.gaurabh,

Good. Can you try generating a new JWT, maybe it’s expired?

Thanks,
Tommy

Hi @tommy. No luck. Can you please tell what is the exact url for List Users API I should use ? And What are the exact steps to be followed when we log in to dev account for getting API key and Secret key ?

Hey @gupta.gaurabh,

Here is the reference for the List Users API.

GET https://api.zoom.us/v2/users

"Authorization": "Bearer JWT_TOKEN_HERE"

Here is how you can get JWT or OAuth credentials.

Thanks,
Tommy

1 Like

I have the same issue

1 Like

Hey @unit1, thanks for posting and using Zoom!

Please share more details about your issue.

Thanks,
Tommy

I am actually trying to get the list of all the meeting for the user. I am using the coldfusion for the server side and the url https://api.zoom.us/v2/users/unit1/meetings

Hey @unit1,

I just tested and it worked. How are you generating your JWT Token?

Thanks,
Tommy

Hi, I am also having the same problem. Has the issue been resolved?

Having similar issues. I copied the JWT token generated from the Zoom Backend (where i also find api key and secret) and also copied the example from github (https://github.com/zoom/zoom-api-jwt/blob/master/index.js) But still get: { code: 124, message: ‘Invalid access token.’ }

I set the JWT to expire in 90 days so its valid. I can’t get it to work. Am I missing something here?

I just created a new JWT app and triple checked all credentials and am also facing this error :frowning:

Guys, I think this issue is confirmed and reported in this post Can not create JWT app.

Maybe someone wants to lock this and edit the title of the other one since thats where the staff replied?

We faced same issue, and got
“code”: 124, “message”: “Invalid access token.”

Following the doc online, create JWT app with api key/secret, and generate Token for 1 week.
And it never work, whether using PostMan with Bearer Token/ or using C# code with header request.AddHeader(“authorization”, $“Bearer {token}”);

just wondering is anybody can help here?

Hey Everyone, we are aware of this issue and are working to fix it asap.

Stay updated here: Developer impacting changes during COVID-19

Thanks,
Tommy

Thanks tommy, we reactivate JWT app, and regenerate Token, that token works fine now.
But if we dynamical create a token using API key/secret, and give expired for 60 minutes etc.
That token still not work, we using C# JWT dotnet library

Hey @alan.chen, glad to hear test token is working now.

Was the token working before for you when generating using the C# library?

Thanks,
Tommy