Inactive or disable video of host or participant before joining the zoom meeting not working

Description
We are creating a zoom meeting for some users where we need control to inactive or disable Host or participant video while joining the zoom meeting.
We are creating meeting with zoom API for which we are sending this data.

Error?
Its works for mute participants but not for video.

API Endpoint/s?
{“audio”: “both”, “use_pmi”: false, “jbh_time”: 0, “watermark”: false, “cn_meeting”: false, “focus_mode”: false, “host_video”: true, “in_meeting”: false, “waiting_room”: false, “approval_type”: 2, “breakout_room”: {“enable”: false}, “enforce_login”: false, “auto_recording”: “none”, “device_testing”: false, “encryption_type”: “enhanced_encryption”, “mute_upon_entry”: true, “private_meeting”: false, “join_before_host”: true, “alternative_hosts”: “”, “participant_video”: false, “show_share_button”: false, “close_registration”: false, “email_notification”: true, “enforce_login_domains”: “”, “host_save_video_order”: false, “allow_multiple_devices”: false, “global_dial_in_numbers”: [{“city”: “San Jose”, “type”: “toll”, “number”: “+1 6699009128”, “country”: “US”, “country_name”: “US”}, {“city”: “Tacoma”, “type”: “toll”, “number”: “+1 2532158782”, “country”: “US”, “country_name”: “US”}, {“city”: “Washington DC”, “type”: “toll”, “number”: “+1 3017158592”, “country”: “US”, “country_name”: “US”}, {“city”: “Chicago”, “type”: “toll”, “number”: “+1 3126266799”, “country”: “US”, “country_name”: “US”}, {“city”: “Houston”, “type”: “toll”, “number”: “+1 3462487799”, “country”: “US”, “country_name”: “US”}, {“city”: “New York”, “type”: “toll”, “number”: “+1 6465588656”, “country”: “US”, “country_name”: “US”}], “meeting_authentication”: false, “global_dial_in_countries”: [“US”], “alternative_host_update_polls”: false, “registrants_confirmation_email”: true, “registrants_email_notification”: true, “alternative_hosts_email_notification”: true, “approved_or_denied_countries_or_regions”: {“enable”: false}, “request_permission_to_unmute_participants”: false}

Additional context
We are able to create meetings using other parameters and its works well like
waiting room enabled, Auto record or mute participant, only this one is causing issue.

Hi @deepak5 ,

I am unable to reproduce this in my testing. Can you please submit a support request: https://devsupport.zoom.us/hc/en-us

Please include:

  • the full api request/response
  • meeting id where behavior is observed
  • short screencast/recording of the the behavior

Thank you!