Initialization of SDK fails

Description
We received an email stating that we needed to upgrade to a minimum of Zoom SDK version 5.9 by November 5th. We have been holding off because we are working on the transition to OAuth login. But as of yesterday the SDK version 5.7.6 (1082) has stopped working. It now fails to initialize. I thought this wasn’t going to be enforced until November 5th? Has a mistake been made?

Which iOS Meeting SDK version?
5.7.6 (1082)

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Build and run a project with version 5.7.6 (1082)
  2. See initialization failure.

Smartphone (please complete the following information):

  • OS: iOS 15

Following up on this, it turns out something happened to our app secret. That’s what was causing the initialization error. Sometime yesterday our secret stopped working without any word from Zoom about it, and no indication on our account. I regenerated it and now it works.

@jeremy.provost ,

Would you be able to DM us your SDK key, account ID, meeting IDs, and approximate timeframe of the error logs so that our team can investigate?

cc @boonjun.tan @richard.zoom

Hello, i’d like to inform I had the same error (except I implemented latest zoom SDK (v5.11.10.8019)).

Zoom works fine last week but somehow today when I tried joining meeting, sdk failed to initialize and getting errorCode 6 internalErrorcode 3023 which is invalid SDK key/secret. Weird error because the applied key/secret is the exact same as in zoom project.

But after regenerating the secret now it works fine. I hope i’m not getting this error again because soon the apps will go production.

I’m afraid I don’t have the step to reproduce the error. Does the SDK secret expires or something else happened? Thanks in advance.