Invalid access token, does not contain scopes:[] when calling Deeplink API

Invalid access token, does not contain scopes:[] when calling Deeplink API with a user token.

I am developing user application that on backend exchanges auth_code for access_token and uses that access_token to create a deeplink when user authorizes the app.

It worked for a while but today I started to receive the following error:

{"code":4711,"message":"Invalid access token, does not contain scopes:[]."}

Looks like there is something wrong because the scope list is empty.
The URL: https://zoom.us/v2/zoomapp/deeplink

The app is in the development stage.
Those are scopes set for it on the portal:

  • user:read:user
  • zoomapp:inmeeting
  • zoomapp:inwebinar

I’ve searched the forum but cannot find an answer to an empty scopes for Deeplink API.

1 Like

@chunsiong.zoom , could you please maybe point me in the right direction? Can I somehow investigate that issue? I’ve noticed that there is another topic form yesterday that this Deeplink API suddenly stopped working.

When I run github sample zoomapps-sample-js, same issue happened.

Thx for the input. I’ve found another issue reported on Monday (Failed to get deeplink via https://zoom.us/v2/zoomapp/deeplink).

Looks like something happened on the Zoom backend that broke staff during weekend.

Yeah, I’m pretty sure that some weird things happened on the Zoom backend. This code has been working well for a while, and suddenly it broke.
I’m so disappointed, since our app has just been approved and published on Zoom marketplace.

Hi @pkowalik @synix521 @james11 , I will escalate this on your behalf. I will direct message you all for the following info:

  • recording reproducing behavior (you can record to Zoom and share link)

  • client id

  • dev email associated with credentials making API request

  • API response zm-tracking-id (found in the response headers)

Check notifications for the message.