getDeeplink returns `Invalid access token, does not contain scopes:[]`

I am testing the demo projects zoomapps-sample-js and zoomapps-advancedsample-react. During the installation of these apps, I encountered an error when executing the following code:

const deepLinkResponse = await zoomApi.getDeeplink(zoomAccessToken);

When making a request to v2/zoomapp/deeplink, I receive the following error message:

  "code": 4711,
  "message": "Invalid access token, does not contain scopes:[]"
1 Like

I’ve the same error!

I’m working on the zoom app for some months now and I created 3 zoom applications.
2 of these applications was created before Zoom changed the way to configure the scopes of the zoom app. The deeplink api works correctly with these 2 apps.
And I created the third one with the new configuration of the zoom app. It was working correctly at first and now I have the same error when I try to get the deeplink. My application is correctly created in the zoom client but I don’t have the deep link for the redirection.
This is the error I get from the deepLink api:

data: {
    code: 4711,
    message: 'Invalid access token, does not contain scopes:[].'

In order to do some tests I tried to test the third application with the credential of one of the first app and it works well.
So I suppose there is a bug on the zoom side with the new way to create a Zoom App.

This issue now seems to have been solved.


1 Like

getDeeplink seems to work now. But when Im installing the app, Im having error code 122. @Gurvan Did you get the same error?

Hello @ghassen ,
I nerver had this error before.
Where did you get this ?

I got it when I was installing the app. I was using ubuntu. I switched to windows and I didn’t get the 122 error.
@Gurvan Are you by any chance using an OS different than ubuntu?

Hi @ghassen ,
Your zoom client is installed on Ubuntu, is that what you mean?

Personnaly I started to work on Ubuntu but the zoom client is not fully compatible with the zoom apps. So I switched to windows to use the Zoom client and I have a VM under fedora to host my zoom app.

Here you can see the Supported operating systems.


@Gurvan Thanks, this helped

1 Like