"Invalid access token, userMeetingRecordings field does not contain required scopes."

Hi
I want to create Server-to-Server application and then use GraphQL to list cloud / meeting recordings. I managed to get access token but then doing the GraphQL query I get

"Invalid access token, userMeetingRecordings field does not contain required scopes."

When I get the access token I get list of scopes and the userMeetingRecordings is really not there. But this scope “cloud_recording:read:list_user_recordings:admin” was added.

I have created

  • Account-level app
  • Server-To-Server OAuth

I am the owner of the account of Zoom Workspace Pro account.

Could someone please help me to make GraphQL query to work under my account?

Thank you
Radek

any suggestions? @zoom

anyone here would be willing to help? Maybe someone from Zoom???

Hi @Radek
Sorry for the late reply here!
Let me do some troubleshooting on my end and will get back to you shortly

1 Like

hi Elisa

thank you so much for looking into it. I am getting desperate …

I tried to create new application and it did not help.

I did give all required permissions and it did not help. More info is here

Thank you
Radek

Hi @Radek
Thanks for sharing that link with me!
I was able to troubleshoot this on my end and replicate the issue that you are seeing.
So you are using a General App and adding all recording scopes which I tried replicating on my end and got the same error.

So, in our Docs it is mentioned that to access GraphQL you have to use a Server-to-Server Oauth app:

By generating an access token with a S2S app, I did not get that error

Could you please try again with a Server to Server Oauth app, an add all recording scopes?

If this does not work for you, I will send you a private message with more details.
Cheers,
Elisa

hi Elisa

but in my first post I wrote that I created S2S OAuth application. So what do you want me to create?
I am not using General App.

image

Radek

Ah interesting @Radek
Cause I am able to replicate this issue with a General app not with a S2S.
Please check your DM

Hi, @elisa.zoom

I’m having the same issue, Could you please let me know what should I do to solve the issue? Thanks in advance

Hi @Manuel2
Make sure you create a Server to Server Oauth app and add the right scopes. Then use that app to generate an access token.
You should be able to use that access token to access graphQL

Hi @elisa.zoom ,

I have the same issue with Radek and Manuel. I followed the get start instruction in your link.
However, I got the same error when query, “Invalid access token, meetings field does not contain required scopes”

I also tried other query list in postman Zoom examples. All same error.

I already gave all permission under meetings and dashboard in the Server 2 Server App.

Do you have any idea?

@Radek May I ask did you solve this problem finally? Thank you

Actually it looks like a bug, Zoom developers are just investigating. I hope @Elisa via Zoom Developer Forum could put more light into it.

Radek

Yes @tianhang.qiang @Radek I am still looking into this.
If you try and create a new Server to Server oauth app under the Legacy app category, you should not see this error

@elisa.zoom
I tried to create a new legacy s2s oauth app and used the access token to GET GraphQL. Same error.

Hi @elisa.zoom
I have a similar kind of error. I have generated Server to Server oauth app . Generated an access token with all the scopes. I am generating the access token using POSTMAN and i can see that the scope that I want is part of the access token.
However when i try to access the webinar details using end point it says code": 4711,
“message”: “Invalid access token, does not contain scopes:[dashboard:read:list_webinars:master].” However I have this scope as part of the access token.

What can be the issue here.

@shilpesh.pillai
Can you share the query that you are sending?