Invalid access token with server-side token JWT

Description
Trying to generate a JWS token in a C# application, when testing the generated token with Postman I receive an “Invalid access token”.

Error
{

"code": 124,

"message": "Invalid access token"

}

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT

Which Endpoint/s?
https://api.zoom.us/v2/phone/users

Additional context
When testing the same endpoint with the JWT generated within the Zoom marketplace, authorization worked fine, only server-side generated tokens fail. I decoded the generated token with https://jwt.io/ and everything looks fine.

Hey @micu

Thanks for posting on the Zoom Devforum! I am still learning, but I will try my best to help answer your question. :slightly_smiling_face:

Checkout these related threads that may have the answer you are looking for:

If these threads did not help, please let us know by replying back here and someone from the Developer Relations team will get back to you shortly.

Thanks,
DeveloperBot

Looked into those threads. Not related, I believe.

Hey @micu,

Thanks for reaching out about this, and happy to help.

Are you using the C# library from jwt.io, or a different library? Can you let me know if this thread helps:
C# JWT token invalid - #6 by tommy

If the JWT token generated via the Zoom marketplace is working for you, this is most likely an issue with the code you’re using to generate the token programmatically.

Let me know if either of the resources linked in the attached thread help, though!

Best,
Will

Hi @will.zoom,

Thanks for helping. Yes, I was using a C# library from jwt.io. I ended up using a different library listed there and that solved my problem.

Hey @micu,

Glad to hear that switching libraries did the trick!

Best,
Will