Invalid length for participantId - 1.7.6 and above

We are currently running the WebSDK version 1.7.5 in our production environment with no errors. We attempted an upgrade over the past couple of days to 1.7.7, and are now receiving an error message indicating that the participantId we’re passing in is > 12 characters (which is true). Historically (1.7.5 and prior), passing this participantId parameter allowed us to launch the Zoom session via the WebSDK with a user’s details including the participantId, which then translated into the Participant_ID field in the downstream web-hooks. These participantIds look something like CkltXNm4R322elaVEjRFGQ - and correspond to the user_id field we’re pulling from our Users extracts.

Per some other articles, we tried omiting the participantId from the init’s json completely, instead relying only on the userEmail property. This did NOT work though. Though we successfully recorded the user_name of the joining person in subsequent webhook events, the participant_ID returned was a completely random identifier not tied at all to the account we had joined the meeting under.

1.7.6 and beyond is throwing an Invalid Parameters error indicating that the participantId exceeds 12 characters. This doesn’t make sense because all of the user_id fields exceed 12 characters. It seems like something has fouled up in 1.7.6 and above that confuses the expected lengths of participantId and participant_user_id, which we can’t really supply at init because we think that’s auto-generated.

Which version?
1.7.5 worked/allowed us to pass participantId with lenghts > 12 characters. 1.7.7’s release failed to allow us to do the same thing.

Additional context
For the WebSDK, we really need to provide the user context to the ZoomMtg.Init so that subsequent webhooks correctly identify which user is logged in. We use that information for LOTS of downstream processes, and we can’t rely on the user_name field because it’s not distinct and the formatting differs from the user object. This was definitely working in 1.7.5.

@Tommy or Zoom Team, should I submit some sort of support ticket for this issue?

Hey @jmauck,

The participant ID is meant to be a unique identifier for the participant in the meeting. So basically not Zoom User ID (CkltXNm4R322elaVEjRFGQ), but Participant ID (12).

In the Participant joined webhook example, the participantId is the user_id

Please use an identifier that is less than 12 characters in length.


Hi @tommy, I still think this is a bug. It also looks like sometime in the past week the invalid message has also increased from 12 characters to 16 characters.

In the webSDK “join” spec, it lists the participantId as a valid parameter expecting a UUID:

In 1.7.5 and earlier, this definitely worked when we passed in the userId. Our meetings do not require registration so we’re not able to supply a registrantId.

In 1.7.7, we can bypass the error by not supplying the participantId at all, but that doesn’t work because the participant detail in those cases returns a completely new/random participantId that doesn’t match the user’s ID tied to their zoom account.


Thanks for the additional info @jmauck!

We are looking into this and will get back to you with an updated from engineering. (CS-1798)


Hey @jmauck,

Please see my post here about the participantId: