"Invalid redirect (4,700)" error on correct redirect url

Hi @Pillar , I just put in a request to see if this is an option. Fingers crossed.

Okay @Pillar , so they were able to reproduce the issue and we think we know the root cause. Can you add the url (https://athlane.us.auth0.com/login/callback) to the OAuth Allow List in “Development” tap. Then you should be able to add it successfully for Production.

Hi @gianni.zoom that worked and we are able to save the URL!

Can you grant us an extension for the “Share outside your account” feature? It expired a week ago, I’ve just submitted a request.

Thank you very much for your help

1 Like

Hi @gianni.zoom we now see that we’re able to share our app outside our account - thank you for the approval.

We are now seeing a new error when we try to authenticate: “invalid user id”

I have tried authenticating with 2 zoom accounts, but keep getting this error. I’ve included the raw output we see in Auth0 as well as a video of us going through the authentication flow.

Please advise - thank you!

  "date": "2024-03-20T22:34:36.483Z",
  "type": "f",
  "description": "Invalid user id.",
  "connection": "zoom",
  "connection_id": "con_9imloZr4euH1M1Xp",
  "client_id": "HT93P4TINLs78pgB4VWT7VDWVlZXJVGU",
  "client_name": "All Applications",
  "ip": "",
  "user_agent": "Chrome 122.0.0 / Mac OS X 10.15.7",
  "details": {
    "body": {},
    "qs": {
      "code": "gQjx6rDBWK2_7C3YSeyTvaSbgGn4W-oyw",
      "state": "XcotPAVNli6RrfwZUoJR3IWu8DsGw2_Y"
    "connection": "zoom",
    "error": {
      "message": "Invalid user id.",
      "oauthError": "invalid_request",
      "type": "request-error"
    "session_id": "sIeDBPyJ1DKSsprMoebLChvueyCocL6D",
    "riskAssessment": null
  "hostname": "athlane.us.auth0.com",
  "$event_schema": {
    "version": "1.0.0"
  "log_id": "90020240320223436542354000000000000001223372067180828378",
  "_id": "90020240320223436542354000000000000001223372067180828378",
  "isMobile": false,
  "id": "90020240320223436542354000000000000001223372067180828378"

Hey @Pillar, I’ve reached out to our Marketplace Engineering team to see if they can offer insight into this issue. I’ll be sure to update you when I have more information from them.

When it comes to the users having issues, have you installed the app as those users previously when testing with external accounts?

If so, you may need to uninstall the app first before attempting to authorize it again. Do you have the ability to uninstall the app as one of those users on their installed apps page?

Let me know if that helps. In the meantime, we’ll continue to look into this.

If you’re able to provide the X-Zm-Trackingid for these requests as well that should help us to troubleshoot

Hi @MaxM - we tried removing the app and re-authenticating, but we’re getting the same user error as before. The video below shows the 2 requests we see when we try to authenticate along with their tracking ids.

I’m not sure these are the requests you need to see, so please let us know if you need tracking ids from some other calls.



Hi @MaxM are our video and tracking ids enough for you to diagnose the user id error? Thank you

Hi @Pillar ,

Reviewing your video, I am not sure why you’re getting that error. Can you try following this auth procedure outlined here to install locally so we can rule that out?

Hi @gianni.zoom yes, we can authenticate successfully locally following the steps in the video. We receive a code from the first endpoint and the second endpoint returns valid tokens and scopes.

I assume it’s expected, but this flow does not work when we try it for production (we get the invalid_grant error below)

    "reason": "Invalid Grant",
    "error": "invalid_grant"

Hi @Pillar just sent a private message for some clarification.

Hi @gianni.zoom - replied in dm

Hey @Pillar , this behavior is being investigated by our service engineering teams and I am awaiting results (ZSEE-124096).

1 Like


Any update on this?

Hi @Pillar , no updates yet. Still waiting.

1 Like

Followed up again expressing some urgency.

1 Like

Hi @Pillar , they just got back to me unfortunately. I believe the examples you shared are no longer viable due to the amount of time it’s been. But they’ve offered to set up a meeting with you directly to resolve. I’ve shared your emails and hope you hear from them soon!

Hi @gianni.zoom thank you for your help

We have not heard from the engineering team yet - is there someone we can get in contact with?

Hi @Pillar ,

Max followed up with them but I will too. Please check private message for the email.