Invalid Redirect URL (4,700) on valid redirect url

Description
When a user tries to go through the OAuth Flow on our app, they are stopped with the following error message:

Invalid redirect: https://api.doodle.com/api/svc-zoom-integration/v1.0/oauth/token (4,700)

The error comes even though we have this exact url setup as our Redirect URL in the App settings

image

We are also seeing evidence that some users are able to connect via our OAuth flow, while others cannot.

Error
Invalid redirect (4,700)

Which App Type (OAuth / Chatbot / JWT / Webhook)?
OAuth

3 Likes

Hey, yeah all of a sudden I got this error a few times today when developing a new private app. I have got the error with two urls that I have previously used successfully. This must be a consequence of something going wrong on Zoom’s backend.

Hey, you may have to add the same url to whitelist urls.

3 Likes

Thank you for the tip. I did this and the installation worked. Problem solved.

1 Like

Simply updating the whitelisted url might not help us in our case, since we are dealing with a published app. I think the only way to affect the whitelisted urls would be to add the new whitelisted url and then publish the new app. It might have worked in @danwilson 's case because he is working with an unpublished app, so changing the whitelisted urls would have set in motion all the necessary chain reactions to reset the state on his app and get things working again. He might even find that if he removes the whitelisted url he added and re-saved the app, then things will still work…he just needed a new setting (it wouldn’t have mattered what that new setting was) to get his app out of the invalid state. I am speculating on this, because I have seen Zoom support recommend this trick in the past where they suggest that you update some value on the app (doesn’t matter which one) and save the app to fix a variety of problems.

Plus, I would find it strange that you would need to explicitly whitelist your own redirect URL :thinking:, I would think that Zoom would consider the Redirect URL as inherently “whitelisted”

I have the same problem, it could be your are right, we had it working for a few years without any problems and suddenly it stopped working without any changes on our side. I thought about doing that trick by removing whitelist url and re-adding it again to refresh the app settings but it didn’t work - might be the case the app is published as you are saying so that’s why for some of the ppl it works and for some not. Let’s see what Zoom support can do with that.

FWIW, we have also seen this issue lately when we haven’t made any changes to our redirecting logic. It seems like there is something flake-y going on with Zoom’s redirect / auth process.

Hey @victor-zmurl, @rafal, @MichaelW,

For published apps, can you try regenerating the publishable URL and see if that fixes the issue? If not, please share your app names and I will look into this further.

Thanks,
Tommy

Hi Tommy, I tried that but it does not fix the issue. Regenerate-ing the Publishable URL does not seem to do anything. It still has the same client ID in the URL…

We got a response from developer support saying that they had fixed the problem for us, and it does seem like the problem has been resolved on our end

1 Like

Happy to hear it is working for you now @MichaelW! :slight_smile:

-Tommy

Hey @victor-zmurl,

What is the name of your app? I will take a look.

Thanks,
Tommy

Hey @tommy,

Any chance you can check my app too? I am facing similar problems, I am getting Invalid redirect url (4,700) when trying to connect to the newly added and published Whitelist URLs.

Just to clarify, I added new Whitelist URLs after the app was published and requested the Update Review and it was approved.

App name is Amplify OMS.

Thanks

It’s working for me too! Thanks for looking it at it, Tommy and Ojus!

1 Like

Happy to help @rafal! :slight_smile:

Thanks,
Tommy

Hey @amplifyoms,

I have sent your app info to our engineers to investigate.

Are you still experiencing this issue?

Thanks,
Tommy