"Invalid redirect (4,700)" error on correct redirect url

Hello, we have a beta app (“Pillar, Inc”) that we’re testing and we keep getting this error when we try to initiate an oauth connection from our end:

Invalid redirect: https://athlane.us.auth0.com/login/callback (4,700)

That auth0 URL is exactly what’s listed in our app’s “OAuth Redirect URL” field in the production settings (see image)

We have tried to add the URL to the “OAuth Allow Lists”, but while the page says it’s saved, when I refresh the page, the URL is gone. Can you advise on how to resolve this? We are trying to get this working asap so we can submit our app for approval in the marketplace.

Thank you

Bumping this - can someone help us resolve this?

Hi @Pillar ,

Please add the redirect url to your allow list and try again after saving. Let me know if this resolves.

Hi @gianni.zoom thank you for your reply.

We have tried to add the redirect URL to the whitelist as suggested in previous replies for this error, but our changes are not saving.

Please see video below - when we add or change any of the whitelist URLs, the UI says “Saved”, but the changes don’t persist.

Hi @Pillar , seems like a bug. Please check your messages.

Seems like a few people may be having this issue and our engineering team is looking into the root cause.

1 Like

Hi @gianni.zoom is there an update on this issue?

Hi @Pillar ,

The root cause issue is web logic error that our team is working on. Waiting for a response from them. Just followed up.

1 Like

@Pillar , can you try saving the redirect url again to the allow list?

Hi @gianni.zoom we are still seeing the issue (see video below)

Thank you I will let the team know immediately @Pillar

1 Like

@Pillar can you please send the tracking id for the “add an allowlist” action? This will help us debug.

@gianni.zoom where can we find the tracking id?

The response I see from the PATCH request is below - is that what you need?


    "applicationId": "87cu-bH6TpCQr8ohz_O9kg",
    "displayName": "Pillar, Inc",
    "icon": "/soeCBYRHTkqCpaH0ncKI9A/QcyTf8a0RYKlHboBzk0L8A/app/sSg89i9lTGWxQHeeKLmbrA/2uZV3ecDTgSUEyJfPBfAoA.png",
    "clientId": "dMMRSGtcRNWS9jHkin1FJg",
    "clientSecret": "nNrnondcGtrFvNUDOeXDXjq0BJ8aOZ9S",
    "redirectUri": "https://athlane.us.auth0.com/login/callback",
    "missingRequiredHeaders": null,
    "scopes": [
    "unableDeleteScopes": [],
    "redirectUrls": [
    "distribution": null,
    "distExpTime": null,
    "distExpNotifPoints": null,
    "whitelistStrictMode": null,
    "whitelistSubdomainStrictMode": null,
    "scopeNotes": null,
    "homeUri": null,
    "modifiedTime": null

Hi @Pillar ,

On the app credentials page, please do the following:

@gianni.zoom I’m not seeing anything when I filter by “advantage”, but here are the tracking ids for the 2 requests I see when I enter a new URL to the allowlist



Okay thank you @Pillar , I’ve shared!

1 Like

Hi @gianni.zoom any update on this?

Hi @Pillar , I just pushed again for a follow up on this fix. Thank you for checking in!

Hi @Pillar ,

Can you delete the url from “OAuth redirect url”, have it save and then re-add?

It should also be automatically adding the redirect url to the allow list.

Can you please provide a short video of this like you did before?

If you run into the error again, please send tracking id. We are not sure why this issue is persisting but I’m working closely with the right team to decipher the root!

Hi @gianni.zoom thank you for taking a look. Please see video below - we tried removing the redirect URL, adding it back, and adding it to the whitelist. It’s just not saving.

Until there’s a general fix, can it be added manually on the backend by your team? The URL is: https://athlane.us.auth0.com/login/callback