Invalid redirect url (4700) even though I whitelisted the root domain

We have a Zoom integration (Setster Appointment Scheduling) that is deployed on multiple servers which have different subdomains. For the main domain(, the application is working as expected, but from a server which uses a subdomain we receive the Invalid redirect url (4700) error. We added the as the redirect url and also added this to the withelist. We also added the full subdomain and domain url to the whitelist and still no luck.

Invalid redirect: “the redirect url. removed this for security reasons” (4,700)

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Hey @gzg

Thanks for posting on the Zoom Devforum! I am still learning, but I will try my best to help answer your question. :slightly_smiling_face:

Checkout this related thread that may have the answer you are looking for:

If this thread did not help, please let us know by replying back here and someone from the Developer Relations team will get back to you shortly.


We’ve looked over all items posted for this issue and most of the tickets end in “Everything is working now without us doing anything” so this won’t help us as we already tried the solutions from that ticket.


Hey @gzg,

Thanks for reaching out about this, and happy to help.

Is it possible to share a screenshot of the error you’re running into, including the full URL in the browser when you run into this issue? If you could share your OAuth app settings as well, this will be helpful to debug.

If you haven’t yet seen this thread, please check this out as well:


I’ve seen the thread and did that already but this did not help. Bellow you can find the required screenshots.

Hey @gzg,

Thanks for sharing these details. I just DM’d you to set up some time to debug further if it’s helpful.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.