OAuth: Invalid redirect (4700) error (despite whitelisting)


I am getting “Invalid Redirect… (4700)” error during the OAuth flow. I have seen numerous threads with the exact same error, and have pretty much tried all suggestions mentioned in them - including the most common one of whitelisting the redirect url. None of them seem to get me past this error. I have triple-checked that the URLs match.

(I have another private project where the configuration is very similar - except with a dev testing URL instead of the production one. And in this, OAuth seems to work just fine.)

Could someone from Zoom help debug this from the backend maybe? Also, given that this specific error seems to happen so frequently, would also appreciate an FAQ page of sorts to help newbies facing this.

Hello @sid
I will send you a private message so I can help you trouble shoot this error!

Thanks for the help, @elisa.zoom

Just for the reference of others who might run into this,

  • the “development” redirect URL also needs to be added to the “Allow List” for the “production” OAuth to work.
  • the redirect URL added to the Allow List needs to be the complete domain (Ex: auth.example.com); wildcard domains (*.example.com) will not work.
1 Like

Thanks @sid for sharing our findings with the community!

1 Like

This topic was automatically closed 368 days after the last reply. New replies are no longer allowed.