Is there a way to decrease video artefacts when streaming the raw video data?


  • I’m working with Meeting SDK for Linux, (zoom-meeting-sdk-linux_x86_64-
  • caps returned by the SDK are the following: 320x180, frame: 25, 640x480, frame: 25, suggested_cap: 640x480, frame: 25

When sending YUV frames using the one of available formats, I’m getting video artefacts, especially visible when sending 4x3 video frames with textual data.

I’m attaching screenshots that show together:

  • original image
  • YUV file generated by ffmpeg and played with ffplay. Exactly the same YUV file is used in the following code
mVideoSender->sendVideoFrame(yuvData, frameWidth, frameHeight, 
		frameLen, 0, FrameDataFormat_I420_FULL);
  • how does Zoom meeting look with the given file

(sorry, cannot attach them here somehow)

640x480 - text

320x180 - text

Here are my video settings, as reported by Meeting SDK

[2024-02-12 10:58:08.310796][info]: [0x00007fb3540a5a80] : IsHDVideoEnabled false
[2024-02-12 10:58:08.310856][info]: [0x00007fb3540a5a80] : IsAlwaysUseOriginalSizeVideo false
[2024-02-12 10:58:08.310901][info]: [0x00007fb3540a5a80] : IsVideoAutoFramingEnabled false
[2024-02-12 10:58:08.310956][info]: [0x00007fb3540a5a80] : IsOptimizeVideoQualityEnabled true
[2024-02-12 10:58:08.310997][info]: [0x00007fb3540a5a80] : IsOptimizeVideoQualitySupported false
[2024-02-12 10:58:08.311061][info]: [0x00007fb3540a5a80] : IsAlwaysShowNameOnVideoEnabled true

Is there a way to reduce these video artefacts, e.g. by just putting video frame of supported size (640x480 or 320x180) in the middle of Zoom participant window as is, without any scaling/resizing?


@lyolik , Meeting SDK for Linux should support up to 1080p.
You should be getting 720p and 1080p in the capabilities. I’ll be sending you a PM to check on your account,

Seems like from the screenshots, the artefacts might be from our compression at low resolution. We should try again with higher resolutions

Thanks, indeed, it’s turned out I’ve missed the step "contact Zoom support and request “Meeting SDK For Web 720p” feature to be enabled for my account.

Now it works and I’m getting 1280x720 cap and able to stream HD content.

[2024-02-16 15:26:44.425946][info]: [0x00007f29f786d580] : [Main->VideoManager]  320x180, frame: 25
[2024-02-16 15:26:44.425967][info]: [0x00007f29f786d580] : [Main->VideoManager]  640x480, frame: 25
[2024-02-16 15:26:44.425991][info]: [0x00007f29f786d580] : [Main->VideoManager]  1280x720, frame: 25
[2024-02-16 15:26:44.426013][info]: [0x00007f29f786d580] : [Main->VideoManager]  suggest_cap: 1280x720, frame: 25

Thank you very much for your help

1 Like