Issues in uploading app in appstore

Zoom SDK version no: v5.4.54802.0124

App Store Connect Operation Error
ERROR ITMS-90087: “Unsupported Architectures. The executable for HelloParent.app/Frameworks/MobileRTC.framework contains unsupported architectures ‘[x86_64, i386]’.”

App Store Connect Operation Error
ERROR ITMS-90209: “Invalid Segment Alignment. The app binary at ‘HelloParent.app/Frameworks/MobileRTC.framework/MobileRTC’ does not have proper segment alignment. Try rebuilding the app with the latest Xcode version.”

App Store Connect Operation Error
ERROR ITMS-90125: “The binary is invalid. The encryption info in the LC_ENCRYPTION_INFO load command is either missing or invalid, or the binary is already encrypted. This binary does not seem to have been built with Apple’s linker.”

App Store Connect Operation Warning
WARNING ITMS-90080: “The executable ‘Payload/HelloParent.app/Frameworks/MobileRTC.framework’ is not a Position Independent Executable. Please ensure that your build settings are configured to create PIE executables. For more information refer to Technical Q&A QA1788 - Building a Position Independent Executable in the iOS Developer Library.”

Hey @helloparent,

Thanks for using the dev forum!

Errors like these can be caused from a variety of issues. So lets troubleshoot :slight_smile:

  1. There are two versions of the SDK, one is device only and the other is device and simulator. The device and simulator version will not work for shipping to the app store, can you verify you are trying to ship the device only version?
  2. Can you verify you have disabled bitcode for all of your targets?
  3. Can you provide a screenshot of your “frameworks, libraries, and embedded content” section of your main target build settings?
  4. Are you also using the MobileRTCScreenShare.framework? If so, can you provide a screenshot of your “frameworks, libraries, and embedded content” section of your broadcast extension target build settings?
  5. What Xcode version are you using?

Thanks!
Michael

Hey Michael Condon,

  1. Verified device only SDK and replaced with existing - screenshot 1
  2. Device is not connected after replaced device only library. - screenshot 2
  3. Installed the required one as per the second screenshot.
  4. Now the device is not connecting with Xcode - screenshot 3.
  5. Attached all screenshots as you asked in previous post.

Hey @helloparent,

What is the iOS deployment version for you app?
What is the iOS version of your iPhone?

Thanks!
Michael

iOS deployment version : 11
iOS version of iPhone : 14.4

Successfully uploaded into app store after changed zoom library which is only for device. Additionally, we facing issues frequently when initializing the zoom library.

error: assertionFailure(“SDK Authorization failed with MobileRTCAuthError: (returnValue).”)
returnValue: overTime

Hi @helloparent,

This error code indicates that the SDK auth request has timed out. In order to minimize the chances of this happening, please ensure that your device maintains a stable network connection at all times while using the SDK.

Thanks!

1 Like

Hi jon,
When there is no stable network it breaks(crash) the app. I shall remove that particular code?.

assertionFailure(“SDK Authorization failed with MobileRTCAuthError: (returnValue).”)

Hey @helloparent,

Yes, that code should be replaced with something that does not cause an assertion failure. The assertion failure was put into the demo app code just to bring attention to the callback for developers learning how to use the SDK. It is not necessary (or recommended) to fail here :slight_smile: I would replace “assertionFailure” with “print” or something similar.

Thanks!
Michael

Hi Michael Condon,

How to enable the camera flip option? back camera to front camera and front camera to back camera.

This is my UI customization code

func zoom_UI_customization(){
    let settings = MobileRTC.shared().getMeetingSettings()
    settings?.setMuteVideoWhenJoinMeeting(true)
    settings?.setAutoConnectInternetAudio(true)
    settings?.setMuteAudioWhenJoinMeeting(true)
    settings?.meetingShareHidden = true
    //        settings?.disableDriveMode(true)
    settings?.meetingLeaveHidden = false
    settings?.meetingInviteHidden = true
    settings?.meetingTitleHidden = true
    settings?.hintHidden = true
    settings?.topBarHidden = true
    settings?.meetingChatHidden = true
    settings?.copyMeetingUrlDisabled()
    settings?.meetingPasswordHidden = true
    //        settings?.hostLeaveHidden = true
    settings?.setFaceBeautyEnabled(true)
    settings?.enableShowMyMeetingElapseTime(true)
    
    
}

Hey @helloparent,

When you enable topBarHidden it will hide the camera switch button.

Thanks!
Michael