Joining Fail with Error Code 1 React App Typescript

Hi! I’m sorry if this is the n-post about this error, but I couldn’t resolve it. I’m creating a react app using the web sdk. I followed the tutorial that starts at https://marketplace.zoom.us/docs/sdk/native-sdks/web/getting-started/integrate splitting the code in 2: a firebase function where I generate the signature and a repository which receive from the function the signature and call ZoomMtg.init/join. I’m working from a machine which mount debian using the download app of zoom (I’ve also tried from my mac book and it’s the same) and creating a meeting from there, so the meetingId is real. The app is JWT type.

Error
A popup with title as “Joining meeting timeout.” and description “joining fail”.
{method: “join”, status: false, errorCode: 1, errorMessage: “joining fail”, result: null}

    dependencies: {
    "@testing-library/jest-dom": "^4.2.4",
    "@testing-library/react": "^9.3.2",
    "@testing-library/user-event": "^7.1.2",
    "@types/jest": "^24.0.0",
    "@types/jquery": "^3.3.33",
    "@types/jsonwebtoken": "^8.3.8",
    "@types/node": "^12.0.0",
    "@types/react": "^16.9.0",
    "@types/react-dom": "^16.9.0",
    "@types/react-redux": "^7.1.7",
    "@zoomus/websdk": "^1.7.2",
    "awesome-typescript-loader": "^5.2.1",
    "bootstrap": "^4.4.1",
    "firebase": "^7.12.0",
    "inversify": "^5.0.1",
    "inversify-react": "^0.4.3",
    "jsonwebtoken": "^8.5.1",
    "react-bootstrap": "^1.0.0-beta.17",
    "react-scripts": "3.4.0",
    "redux-devtools-extension": "^2.13.8",
    "reflect-metadata": "^0.1.13",
    "source-map-loader": "^0.2.4",
    "typescript": "3.8.3",
    "react": "16.8.6",
    "react-dom": "16.8.6",
    "redux": "3.7.2",
    "react-redux": "7.1.0",
    "jquery": "^3.4.1",
    "lodash": "^4.17.14",
    "redux-thunk": "2.2.0"
  }

This is my ZoomRepository which has getSignature and joinMeeting.

getSignature(config: any): Promise<string> {
    const getSignature = firebase.functions().httpsCallable("getSignature");
    return getSignature()
        .then((response: any) => {return Promise.resolve(response.data);})
        .catch((error: any) => {return Promise.reject(error.message);})
}

I’m using chrome, but the same error is thrown on firefox.

Until yesterday I’ve worked with the basic plan, but then in the evening I’ve upgraded the account to Pro. If you need it, this is the meetingId: 818435529. Let me know if you need more info, cheers!

Hey @corrado4eyes, thanks for posting and using Zoom!

Seems like the issue could be with your signature. Can you send me one of your generated signatures so I can debug?

Thanks,
Tommy

Yes sure… Signature: “djhCcUhNakdUNmlqRThKcnA2aFdYQS51bmRlZmluZWQuMTU4NTIwOTAzNjM0Ni51bmRlZmluZWQubUhhZ1FMeFUrelhiYVZBdDJUSXkvdjczVkk5U25xSjAySFRXRlF3VmhqTT0”

Hey @corrado4eyes, when base 64 decoding your signature I see both your meetingID and role are undefined.

Make sure you are passing in your meetingID, and 0 or 1 for the role.

Thanks,
Tommy

Oh thanks for letting me notice about that! Fixed… However still getting joining fail

Hey @corrado4eyes,

What meeting number are you using?

Thanks,
Tommy

The meeting id now is: 786353789

Hey @corrado4eyes,

Can you try the updated signature code.

We added more expiry time to it.

Thanks,
Tommy