Joining meeting timeout - Your connection has timed out and you cannot join the meeting. Verify your network connectivity and try again

Description
I’m setting up a proof of concept application using the Web SDK and seeing the above error.
I’ve also got two console errors showing.

  1. Warning: validateDOMNesting(…): < h1> cannot appear as a descendant of < p>.
  2. Warning: Invalid DOM property playsinline. Did you mean playsInline?

Error
The main issue is that I cannot join a webinar/meeting. It just tells me that the connection has timed out.
I don’t believe it has anything to do with connectivity.
I’ve read loads of articles and tickets for seemingly the same thing but no resolutions. These tickets were mostly from a 1.7.x and 1.8.x versions so has this bug existed since then?
Is there in fact no way to embed a webinar?

It stands a fair chance I’m doing something glaringly stupid.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT

My JavaScript file is below but it’s a copy of the one in the documentation.

Thanks in advance

import { ZoomMtg } from '@zoomus/websdk'

// For Global use source.zoom.us:
ZoomMtg.setZoomJSLib('https://source.zoom.us/1.9.5/lib', '/av');

// prepare required files
ZoomMtg.preLoadWasm();
ZoomMtg.prepareJssdk();

// const zoomMeeting = document.getElementById("zmmtg-root")

const meetConfig = {
    apiKey: 'XXXX',
    meetingNumber: '123456789',
    leaveUrl: 'https://aapoc.test/ended',
    userName: 'Name',
    userEmail: 'email@email.com', // required
    // passWord: 'password', // if required
    role: 1 // 1 for host; 0 for attendee
};



function getSignature(meetConfig) {
    // make a request for a signature
    fetch(`https://aapoc.test/api/signature`, {
        method: 'POST',
        body: JSON.stringify({ meetingData: meetConfig })
    })
        .then(result => result.text())
        .then(response => {
            // call the init method with meeting settings
            ZoomMtg.init({
                screenShare: true,
                isSupportChat: true,

                leaveUrl: meetConfig.leaveUrl,
                isSupportAV: true,
                // on success, call the join method
                success: function() {
                    ZoomMtg.join({
                        // pass your signature response in the join method
                        signature: response,
                        apiKey: meetConfig.apiKey,
                        meetingNumber: meetConfig.meetingNumber,
                        userName: meetConfig.userName,
                        passWord: meetConfig.passWord,
                        // on success, get the attendee list and verify the current user
                        success: function (res) {
                            console.log("join meeting success");
                            console.log("get attendee list");
                            ZoomMtg.getAttendeeslist({});
                            ZoomMtg.getCurrentUser({
                                success: function (res) {
                                    console.log("success getCurrentUser", res.result.currentUser);
                                },
                            });
                        },
                        error: function (res) {
                            console.log(res);
                        },
                    })
                }
            })
        });
}

getSignature(meetConfig);

Meeting number need to be a from a real meeting you created, not ‘123456789’

Hi,
I have used real numbers, I just didn’t include them here.

To be clear is the meeting number this one Webinar ID: **** but minus the spaces?
I’m still getting the same error. I just tried this as well. **** and still seeing The Meeting Number is wrong

My Signature is

I hope you can help, I’m trying to port all our webinars over to Zoom but at the moment this is preventing me.

Doing further testing, it seems whatever meeting number I enter is wrong.
I have tried creating a meeting, but it’s a webinar I need.

Can anyone guide me, it would be very much appreaciated.

Hi folks,
Me again, I’m just at an utter loss.

I’m getting this error

  1. errorCode: 3706
  2. errorMessage: undefined
  3. method: “join”
  4. result: “The meeting number is wrong.”
  5. status: false

Hey @lyleyboy ,

Your signature looks correct. Try checking the browser console to see if the whole error message is being logged.

You can also show the true error message in the error popup ui by adding the following lines of code to your project:

// loads language files, also passes any error messages to the ui
ZoomMtg.i18n.load('en-US');
ZoomMtg.i18n.reload('en-US');

You can put them under your 2 prepare required files lines.

Before:

image

After:

image

Thanks,
Tommy

1 Like

Has this been fixed in Web Client 1.9.6? I can’t seem to replicate it anymore.

edit: yup. rolled back to 1.9.5 and the error message displayed the generic “Connection has timed out error”. Updating to 1.9.6 fixed it.

@tommy It would be really helpful if bug fixes like this were noted in the release notes. Would save your partners time trying to QA platform releases.

Hey @ckarpyszyn,

I’m glad that helped.

I absolutely agree! We are working internally to make sure that we improve our communication to partners and developers.

Thanks for your feedback!

Thanks,
Max