JTW app - "Invalid access token." error on API calls

Description
Hello!
For all JTW apps created today, we’re getting “Invalid access token.” error, after creating the JTW token for Zoom API authentication. We receive the same error, even if we use the test JWT token generated on the JWT app credentials page.
IMPORTANT: Using any other JWT App, which was created before today (mind you - JWT App creation was failing during the weekend), is working normally.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT

Which Endpoint/s?
webhooks/options

How To Reproduce (If applicable)

  1. Create a new JWT app
  2. Use the JWT token listed on the credentials page, or create one yourself, it’s the same result
  3. Try to use one of the API endpoints

To reproduce you could even use your own example (Sample code at the bottom of the page) at: https://marketplace.zoom.us/docs/guides/auth/jwt

1 Like

Hello, I created my app 2 days ago, it was working, now I have the same problem…

Thanks for reporting this issue! I have made our engineering team aware of this and will provide an update here once the issue is resolved. We apologize for the inconvenience that this is causing.

Our engineers have indicated that this issue should now be resolved. If you are still seeing errors, could you try deactivating the JWT app and re-creating again? Let us know! Thank you for your patience!

I have deactivated the JWT application and it is not possible to create a new one to be able to generate the token again.
How can I do it?

Thank you for your collaboration

Deactivated, regenerated again the secret key but same error

After deactivation and reactivation, it’s working as expected. Thank you!

@shrijana.g Unfortunalty I’m usign the wordpress plugin and I deactivated and activated again the application but still the same error invalid access token. there is something else that I have to do ?

Even tho, I used the JWT token for testing purposes after deactivate and reactivate again and I’m still getting the same issue.

Any suggestions here @tkrevh

1 Like

Maybe try to re-create your JWT token?

@tkrevh I deactivated, re-activated, regenerated a new API Secret, then used the JWT Token for testing purposes and I’m still getting the same issue

I tryied to regenerete, deactivate and all possible option but still the sam problem. I’m thinkig to cancel the subscription and ask the refund… are 4 days that I’m not able to use it.

1 Like

Btw mine was created yesterday, so How do I supposed to start to develop on this if this is primary functionality and without this we are unable to do anything?

Unfortunately for some accounts, due to caching issue, it seems to still persist and the eng team will work on restoring it individually. If you have already provided me your Account Numbers via messgae, you do not need to provide it again. You could just let me know that it is still not working on your account. If you have not yet provided me your Account Number, please do so via message. Thank you.

Unfortunatly I have always the same problem and becoming tired of this situation… How long I have to wait?

1 Like

Hi everyone,

For those of you who provided your account numbers via message, it should work now. Please check and let us know.

Hi,

I’ve sent you a message

Hey @marco.g,

Did trying what Shrijana suggested not work?

Thanks,
Tommy

Yes, I’ve deactivated our JWT app, wait some hours, enabled again, and with the new API secret I’m still get ‘Invalid access token’

@tommy I can confirm, it doesn’t help with every account. Some accounts are still experiencing issues.