Meeting update patch - enforce domain does not work

In the following API -

there is a parameter for enforcing domain - ```

We have applied this for a meeting but it does not seem to change behavior as users from other domains could still join the meeting

Hey @yoavc,

In order to set a login domain a few pre requisites are required.

  1. You must turn on the “Only signed-in users can join meetings” setting here

  2. You must turn on AND add a default domain on the “Only signed-in users with specified domains can join meetings” here.

Once you do this, enforce_login and enforce_login_domains will work on the create meetings and update meetings endpoints.

  "topic": "Custom Domain Login",
  "type": 2,
  "duration": 30,
  "start_time": "2019-08-01T20:00:00Z",
  "settings": {
    "enforce_login": true,
    "enforce_login_domains": ""

A few things to note:

  1. This only works for scheduled (meeting type 2) or recurring (meeting type 3 and 8). Instant meetings (meeting type 1) matches what you have in your account settings.

  2. You can specify a different domain via the API endpoints then what you have in your account settings. You don’t have to add each domain to your settings in order to use via the API. You only need one default domain.

  3. If you don’t specify enforce_login via the API it will fallback to what you have in your account settings. If you don’t specify enforce_login_domains via the API, it will fallback to your default domain in your account settings.

Let me know if this helps!