Restful api create-a-meeting. set enforce_login to true, bug join metting can't use login, why?


#1

create meeting api https://zoom.github.io/api/#create-a-meeting.
restful api create-a-meeting. set enforce_login to true, but user join metting not need login, why?

the body is
{“topic” => “demo”,
“type” => 1,
“start_time” => “2019-01-24 16:40:00”,
“duration” => 120,
“timezone” => “shanghai”,
“password” => “111111”,
“agenda” => “demo demo demo demo”,
“settings” => [
‘approval_type’ => 1,
‘enforce_login’ => true
]
}

and the api response

[host_video] => 1
[participant_video] => 1
[cn_meeting] =>
[in_meeting] =>
[join_before_host] =>
[mute_upon_entry] => 1
[watermark] =>
[use_pmi] =>
[approval_type] => 2
[audio] => both
[auto_recording] => none
[enforce_login] =>
[enforce_login_domains] =>
[alternative_hosts] =>
[close_registration] =>
[registrants_confirmation_email] => 1
[waiting_room] =>

why ?


#2

Hi @yyl,

Within your Zoom Account, can you check to see if “Only signed-in users can join meetings” is set and locked? This might be the reason why.

Thanks


#3

thanks, not found the setting “Only signed-in users can join meetings”. my zoom account
is 1203199, help me check it. thak you very much.


#4

@yyl,

Please go to https://zoom.us/account/setting. Should be under Account Management -> Account Settings, then you should see Only signed-in users can join meetings. Can you verify that it’s turned on and locked?

Thanks


#5

hi, thanks.
I find the setting.
but I would like to know the setting can’t set up by restful api to a meeting? other’s meeting keep defoult.

thanks.


#6

Hi @yyl,

Currently, it has to be set within the Zoom portal.

Thanks