Meeting window that always ignore full screen mode

Problem
I need to open Zoom meeting window (the window after user joins to the meeting) that always ignore fullscreen mode, even user set specific option in settings

What I did
I have tried to change MeetingSettingCmd_AutoFullScreenWhenJoinMeeting:

let error = ZoomSDK.shared()?.getSettingService()?.getGeneralSetting()?.enableMeetingSetting(false, settingCmd: MeetingSettingCmd_AutoFullScreenWhenJoinMeeting)

Result
Meeting window starts in full screen (even if I set false for MeetingSettingCmd_AutoFullScreenWhenJoinMeeting)

Question
Could I do something additional to present meeting window that always ignore full screen mode?

Note
I don’t use a custom UI:
needCustomizedUI == false

Thanks!

Hi @anton.yereshchenko, thanks for the post.

What is the value of the error constant returned from the enableMeetingSetting method?

Are you able to properly disable this setting through the default setting window, or does that have the same behavior as calling into the method?

Thanks!

Hi @jon.lieblich, thank you for your replay!

The value of the error is always Success
Yeah, it’s ok when I toggle the state through the settings window, but in the case, for example, when I turn on the full screen in general settings, relaunch the app, set full screen to false programmatically - it ignores.

Thanks!

Hi @anton.yereshchenko, thanks for the additional info.

I have tried a few times to reproduce this, configuring the settings both programmatically through enableMeetingSetting combined with the settings tab and am getting the expected behavior for full screen 100% of the time.

Note that if you use the default settings window at all after setting something programmatically, it will override that setting in favor of what is visible in the settings window. For example, if you initialize the SDK and then call enableMeetingSetting to disable full screen and then open & close the settings window without modifying anything, the full screen setting will be whatever was present in that window.

Thanks!

Hi @jon.lieblich, thank you for the tests.

Have you tried next scenario?

  1. Launch the project:
  • init SDK.
  • set false for MeetingSettingCmd_AutoFullScreenWhenJoinMeeting.
  1. Go to the settings window check ‘Full Screen’ in general tab.
  2. Relaunch the project.
  • init SDK.
  • set false for MeetingSettingCmd_AutoFullScreenWhenJoinMeeting.

What I expect
After relaunch the project MeetingSettingCmd_AutoFullScreenWhenJoinMeeting will set to false programmatically and the meeting window won’t go to the full screen.

What I got
The meeting window will open as full screen window.

Thanks!

Hi @anton.yereshchenko,

After trying a few times following the steps you’ve mentioned, I am still seeing full screen properly disabled.

Are you able to reproduce this by adding code to disable this setting in our sample app? If so, that may help identify where the difference in our approaches is.

Thanks!