MeetingSDK v5.16.0 is now unable to run more than one instance in the same user session

We use a system that starts a meeting, open around 10 breakout rooms, an join one “Windows Meeting SDK”-based-assistant to each BO.

When trying to upgrade the SDK from v5.15.12 to v5.16.0 the system stoped working. We have found that the SDK is not able to concurrently run more than one instance anymore.

Which Windows Meeting SDK version?
Windows Meeting SDK v5.16.0

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Have the SDK app able to have more than one instance running (by providing distinct 8-char-string-values to initParam.obConfigOpts.sdkPathPostfix)
  2. Run the first instance (fine)
  3. Run the second instance (the “InitSDK(initParam)” call runs well but right after it the “CreateAuthService(&auth)” call returns SDKERR_MODULE_LOAD_FAILED)

Troubleshooting Routes
Rolling back to v5.15.12 makes it possible to run several SDK instances concurrently (and our system restore its functional state).

Device (please complete the following information):

  • Device: Dell Latitude 5430 i7 64GB RAM
  • OS: Windows 11 Enterprise 22H2 build 22621.2283

Additional context
If we keep trying to run the second app in loop, this second instance sucessfuly runs right after we close the first one.

Up to Windows Meeting SDK v5.15.12 it was possible to concurrently run several instances in the same user session.

When running a second instance:

  1. the “InitSDK(initParam)” call runs well
  2. the “CreateAuthService(&auth)” call returns SDKERR_MODULE_LOAD_FAILED)

We tested MeetingSDK v5.16.1, and it is still not possible to run more than one instance of the SDK.

@precisao ,

I’ve tried to look up some information regarding sdkPathPostfix

It seems to be unsupported feature. There were developers who were using it in the past, but it was stated that this might stop working at anytime as it is an unsupported feature.

Moving forward, one of the upgrade path would be to explore Meeting SDK for Linux

Hi @chunsiong.zoom, thanks for clarifying and thanks for the sugestion.

Currently, the Linux SDK isn’t an option for us. Out of dealing with a not so mature product from Zoom, it would require us to rewrite and retest our code that is currently very stable.

Since we can’t relly on using the sdkPathPostfix option, we will try to find a way to define the sdkPath itself, instead of providing the postfix for it. Do you know how can we define the sdkPath when launching an MeetingSDK instance? Is there an environment variable for this?


@chunsiong.zoom, thank you for letting me know the unsuported aspect of the solution.

I could find here in devforum other users who have required running more than one client at the same time: @liminal_andy and @fboncini. Do you still need this, Andy and Fernando?

Their SDKERR_WRONG_USEAGE when Join multiple meetings post must have been the source reference for our implementation.

JFYI, we found that sdkPathPostfix keeps working as expected but, in v5.16.x, having a distinct sdkPath folder is not sufficient anymore for being able to run a second SDK instance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.