Missing Interpretation language

Description
First of all, Italian seams to be a standard language but some functionality aren’t implemented, example:
ZoomMtg.i18n.getAll(‘it-IT’) return english strings and not italian.
By the way, the newly introduced feature “intepretation” does not consider other languages that are not “localized”, so if i add an interpreter for “english - italian”, italian does not appear on web interface, but is correctly visible on windows client.

Error
Interpreter Language not showed on web sdk if it’s different from english, chinese, japanese, german, french, russian, portuguese, spanish or korean

Which Web Client SDK version?
WEB SDK 1.9.5

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Add an intepreter “English - Italian”
  2. On web sdk does,'t appear

Additional context
Also the tooltip showed if Italian is added after meeting start is like "Addend language 0 and other N)
I’ve checked on localized strings and it seams that the only supported languages on web are:

“apac interpretation en”: “English”,
“apac interpretation cn”: “Chinese”,
“apac interpretation jp”: “Japanese”,
“apac interpretation de”: “German”,
“apac interpretation fr”: “French”,
“apac interpretation ru”: “Russian”,
“apac interpretation pt”: “Portuguese”,
“apac interpretation es”: “Spanish”,
“apac interpretation kr”: “Korean”

Hey @assemblea,

Thank you for reaching out to the Zoom Developer Forum. I’m going to speak with my team during our meeting tomorrow to make sure that I have a good understanding of this new Web SDK feature.

I’ll update you here when I have more information.

Thanks,
Max

1 Like

Hey @assemblea,

Thanks for your patience. I spoke with my team and was informed that when a participant has interpretation enabled, they should see the icon to enable this similar to the Zoom Client.

Have you tested setting up participants with interpreters enabled to see if you can spot the Interpretation button?

Thanks,
Max

That is not the problem, interpretation button is correctly visible, but if you try to add a language different from the listed above (english, chinese, japanese, german, french, russian, portuguese, spanish or korean) it will not be displayed on web sdk.




Hey @assemblea,

Thanks for clarifying! I’ll talk with my team to see if this is intended. I expect this is a bug but I’ll need to make sure that we aren’t missing something.

Thanks,
Max

Hi there, just to notify that we need to have other languages on web client as well (e.g. Arabic).

Thank you for confirming, I’ve reached out to our engineering team to see if they can offer any insight into the issue. (ZOOM-281223)

I’ll update you when I have more information.

Thanks,
Max

1 Like

This post was flagged by the community and is temporarily hidden.