Mobile SDK always fails to authenticate on launch

Description
I get MobileRTCAuthError_KeyOrSecretWrong in my AppDelegate onMobileRTCAuthReturn method when trying to authorize my app. I’ve already double-checked that the key and secret match what is in our marketplace SDK app and that that app is activated. We had been using this successfully in previous versions, I do not know when it broke.

Which version?
v4.6.21666.0428

To Reproduce(If applicable)

  1. Happens on launch of the app

Smartphone (please complete the following information):

  • Device: iPhone 8
  • OS: iOS13.3
  • Version 1

Additional context
This is the main way we try to authenticate in AppDelegate:

	let zoomContext = MobileRTCSDKInitContext()
	zoomContext.domain = "https://www.zoom.us/"
	MobileRTC.shared().initialize(zoomContext)
	if let service = MobileRTC.shared().getAuthService() {
		service.delegate = self
		service.clientKey = kZoomSdkKey
		service.clientSecret = kZoomSdkSecret
		service.sdkAuth()
	}

I’ve also tried setting the domain to “zoom.us/”, but see the same behaviour.
I’ve tried setting the jwt token, but then I don’t see the onMobileRTCAuthReturn method called at all.

We just started experiencing the exact same issue today. Our app had been authenticating perfectly fine, but now we’re receiving the MobileRTCAuthError_KeyOrSecretWrong error. Our keys and secrets are definitely correct and our app is activated. We’re also using the zoom.us domain.

Any feedback/guidance on this would be greatly appreciated. This is a major inconvenience for our users.

Hi TimedRight_Webinar_A,

Thanks for the post. Let me contact you shortly.

Thanks!

Hi iScribeHealth,

Thanks for using Zoom SDK. Let me contact you shortly.

Thanks!

We have the same problem too. How can we fix this?

Hi @iScribeHealth. Did zoom solved this problem for you?
Thanks!

Yes, they did. You may want to submit a request on their support page to get faster response time: https://support.zoom.us/hc/en-us/requests/new

We need to create an sdk app, and not a jwt app as stated in doc.
:rage: :face_with_symbols_over_mouth:

Hi @devark,

Thanks for the reply. May I inquire what is the issue you are facing right now and how can I help?

Thanks!

Hi @carson. We were using the credentials from a jwt app, as stated in doc. But for the sdk to authenticate you must use the credentials from a sdk app.
I think it’s better to fix the doc.
Bye

Hi @devark,

Thanks for the reply. Could you provide the link of the doc that needs to fix? I will forward it to the doc team to fix it.

Thanks!