"No permission" error while evaluating the platform


#1

Hi,

I am trying to set up the in-browser JS client example by following the documentation I found here: https://zoom.github.io/zoom-sdk-web/tutorial-getting-started.html . I have thoroughly followed the procedure described there:

 - Installed the Zoom Client

 - Downloaded the code

 - Ran npm install

 - Updated the files with my evaluation API key/secret

 - Ran http-server

 - Created a meeting from the Zoom Client

 - Opened the browser on 127.0.0.1:8081 (that’s what http-server told me)

 - Copypasted the meeting number, added a name, and pressed join.

Nothing happened. 

By looking in the console, the library returned me this string

{status: false, errorCode: 200, errorMessage: “No permission”, result: null, method: “join”}

What did I do wrong?

Update: I tried to set MY userName and MY passWord in the join method, and now I think I managed to connect to an existing session… even if I don’t see anything! The video is not visible, and the system prompts me to perform a phone call to get the audio… Is this the intended behavior? This web client seems pretty useless, this way…


#2

Hello,

I did exactly the same steps and got the same results.

Note: My meeting is going in other device, and via web client I’m trying to join rom my computer.

Hope somebody could help soon, It’s a llitle urgent.

Regards


#3

Can you confirm that you are still receiving this message?

 

I just tested and cannot reproduce.


#4

Hello, I have similar problem right now - https://source.zoom.us/zoom-meeting-1.0.0.min.js responds with HTTP 403: 

I am running sample-app-web on http://127.0.0.1:8080


#5

HI Viacheslav,

 

This seems to be a different issue, investigating…


#6

Hi Viacheslav,

 

Please try again


#7

Hi Joshua,

It works now, thank you


#8

Hi, I actually get the same issue as the OP. I get this “No permission”.

I am simply using the sample code from the Github and I obviously replace the API_KEY and API_SECRET with the one from my account.

Is there any more steps to do ?