Not able to set start with zoom meeting start api

meetingdetails = {
“topic”: “The title of your zoom meeting”,
“type”: 2,
“start_time”: “2022-03-25T07:32:55”,
“timezone”: “Asia/Calcutta”,
“agenda”: “test”,
“settings”: {
“join_before_host”: True,
“approval_type” : 1,
“auto_recording”: “cloud”,
‘private_meeting’ : True,

I have tried using start_time both with z and without z at the end,
In response, ‘start_time’ is always equal to ‘created_at’

{‘uuid’: ‘QrbVGnN4Q7Wm9Dn16LafSg==’, ‘id’: 82236839118, ‘host_id’: ‘K4VMeWdQR7WnrO5tfw1nKg’, ‘host_email’: ‘’, ‘topic’: ‘The title of your zoom meeting’, ‘type’: 2, ‘status’: ‘waiting’, ‘start_time’: ‘2022-10-19T11:53:49Z’, ‘duration’: 60, ‘timezone’: ‘America/Los_Angeles’, ‘agenda’: ‘test’, ‘created_at’: ‘2022-10-19T11:53:49Z’

Hi @chetankhanna767 ,

The reason is because the meeting that you are trying to create is in the past. You can only create meetings for a future time orelse it will take the current time.

Hope that helps

That was dumb on my part.
When the time is in future it returns time in UTC even when I pass the timezone
Is this how its supposed to work ?

Just tried this payload and it works:

"topic": "The title of your zoom meeting",
"type": 2,
"start_time": "2022-11-25T01:32:55Z",
"timezone": "Asia/Calcutta",
"agenda": "test",
"settings": {
"join_before_host": "True",
"approval_type" : 1,
"auto_recording": "cloud",
"private_meeting" : "True"