Null response is coming while creating meeting using zoom api

https://api.zoom.us/v2/users/{userId}/meetings

Hey @tomamt1234,

When posting please fill out the post template so we can have all the details required to help.

Please share your full request URL and body.

Thanks,
Tommy

api:
POST https://api.zoom.us/v2/users/https:/us04web.zoom.us/j/9386870475/meetings

Headers:
Authorization: Bearer eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJhdWQiOm51bGwsImlzcyI6Imk5X0pINE9LUk9DN2RGNmlza3gtTWciLCJleHAiOjE1ODYzNTE4ODAsImlhdCI6MTU4NTc0NzA5M30.WGAdK3xZJBU1rlp6N0IAoc8kwAEiYiesisOIOrocaFQ
Content-Type: application/json

body:
{
“topic”: “personal meeting”,
“type”: “2”,
“start_time”: “2020-04-02T12:02:00Z”,
“duration”: “30”,
“timezone”: “UTC +9”,
“password”: “XXXXX”,
“agenda”: “personal”,
“recurrence”: {
“type”: “1”,
“repeat_interval”: “integer”,
“weekly_days”: “1”,
“monthly_day”: “2”,
“monthly_week”: “1”,
“monthly_week_day”: “5”,
“end_times”: “30”,
“end_date_time”: “2020-04-02T12:30:00Z”
},
“settings”: {
“host_video”: “true”,
“participant_video”: “true”,
“cn_meeting”: “true”,
“in_meeting”: “true”,
“join_before_host”: “true”,
“mute_upon_entry”: “true”,
“watermark”: “true”,
“use_pmi”: “true”,
“approval_type”: “0”,
“registration_type”: “1”,
“audio”: “both”,
“auto_recording”: “local”,
“enforce_login”: “false”,
“enforce_login_domains”: “false”,
“alternative_hosts”: “”,
“global_dial_in_countries”: [
“+91”
],
“registrants_email_notification”: “true”
}
}

Hey @tomamt1234,

You are not passing in a correct userID param.

https://api.zoom.us/v2/users/https:/us04web.zoom.us/j/9386870475/meetings

You need to pass in a userID, userEmail, or the word me.

You can get userIDs and userEmails from the Get Users endpoint.

https://api.zoom.us/v2/users/{userID}/meetings

Thanks,
Tommy

Thanks tommy
api is working now

1 Like

Happy to hear! :slight_smile:

-Tommy

1 Like