Query related to the 'Create meeting' by Zoom REST API

Hi,
We are trying to consume Zoom REST APIs to create and record meetings. We are referring - https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingcreate

The request body is

{
“topic”: “Test Meeting of Recurssive meeting in Browser”,
“type”: “8”,
“start_time”: “2019-07-30 21:00:00”,
“timezone”: “America/Los_Angeles”,
“agenda”: “Agenda of the meeting”,
“recurrence”: {
“type”: “2”,
“repeat_interval”: “1”,
“weekly_days”: “1,2”,
“end_times”: “12”,
“end_date_time”: “2019-08-30 21:00:00”
},
“settings”: {
“host_video”: “false”,
“participant_video”: “false”,
“cn_meeting”: “false”,
“in_meeting”: “false”,
“join_before_host”: “true”,
“mute_upon_entry”: “false”,
“watermark”: “true”,
“use_pmi”: “false”,
“approval_type”: “0”,
“registration_type”: “1”,
“audio”: “both”,
“auto_recording”: “cloud”,
“enforce_login”: “true”,
“enforce_login_domains”: “”,
“alternative_hosts”: “”
}
}

and the response is

{
“agenda”: “Agenda of the meeting”,
“created_at”: “2019-06-17T11:12:23Z”,
“host_id”: “MfZlTyOrSI22Wa__riEfvw”,
“id”: 975578973,
“join_url”: “https://zoom.us/j/975578973”,
“occurrences”: [
{
“duration”: 60,
“occurrence_id”: “1560769920000”,
“start_time”: “2019-06-17T11:12:00Z”,
“status”: “available”
},
{
“duration”: 60,
“occurrence_id”: “1561288320000”,
“start_time”: “2019-06-23T11:12:00Z”,
“status”: “available”
},
{
“duration”: 60,
“occurrence_id”: “1561374720000”,
“start_time”: “2019-06-24T11:12:00Z”,
“status”: “available”
},
{
“duration”: 60,
“occurrence_id”: “1561893120000”,
“start_time”: “2019-06-30T11:12:00Z”,
“status”: “available”
},
{
“duration”: 60,
“occurrence_id”: “1561979520000”,
“start_time”: “2019-07-01T11:12:00Z”,
“status”: “available”
},
{
“duration”: 60,
“occurrence_id”: “1562497920000”,
“start_time”: “2019-07-07T11:12:00Z”,
“status”: “available”
},
{
“duration”: 60,
“occurrence_id”: “1562584320000”,
“start_time”: “2019-07-08T11:12:00Z”,
“status”: “available”
},
{
“duration”: 60,
“occurrence_id”: “1563102720000”,
“start_time”: “2019-07-14T11:12:00Z”,
“status”: “available”
},
{
“duration”: 60,
“occurrence_id”: “1563189120000”,
“start_time”: “2019-07-15T11:12:00Z”,
“status”: “available”
},
{
“duration”: 60,
“occurrence_id”: “1563707520000”,
“start_time”: “2019-07-21T11:12:00Z”,
“status”: “available”
},
{
“duration”: 60,
“occurrence_id”: “1563793920000”,
“start_time”: “2019-07-22T11:12:00Z”,
“status”: “available”
},
{
“duration”: 60,
“occurrence_id”: “1564312320000”,
“start_time”: “2019-07-28T11:12:00Z”,
“status”: “available”
}
],
“recurrence”: {
“end_times”: 12,
“repeat_interval”: 1,
“type”: 2,
“weekly_days”: “1,2”
},
“settings”: {
“alternative_hosts”: “”,
“approval_type”: 2,
“audio”: “both”,
“auto_recording”: “none”,
“close_registration”: true,
“cn_meeting”: false,
“contact_email”: "zoom.integration.kr@gmail.com",
“contact_name”: “Zoom Kumar”,
“enforce_login”: false,
“enforce_login_domains”: “”,
“global_dial_in_countries”: [
“US”
],
“host_video”: false,
“in_meeting”: false,
“join_before_host”: true,
“mute_upon_entry”: false,
“participant_video”: false,
“registrants_confirmation_email”: true,
“use_pmi”: false,
“waiting_room”: false,
“watermark”: true
},
“start_url”: “https://zoom.us/s/975578973?zak=eyJhbGciOiJIUzI1NiJ9.eyJhdWQiOiJjbGllbnQiLCJ1aWQiOiJNZlpsVHlPclNJMjJXYV9fcmlFZnZ3IiwiaXNzIjoid2ViIiwic3R5IjoxMDAsIndjZCI6ImF3MSIsImNsdCI6MCwic3RrIjoiU2Zpd0tRU0ctUkRwSDQtVXJVSUJ0anR0MkJNdVc0NlFhS3ZkQW93T05uQS5CZ1VzU2s4M0wxbFZiVWs0VHk5cmVVZEhWbkpWUXpCV1pIQkxNVTVGVkdwbmNWTkVNbmh6Y21wak9GRlNhejFBTmpVNU1tUTBPVEF3TWpObU9UUTBOekV5T1dJNE5EUXhaVGc0T0RRMk1qRTRNakV5WmpnNE5XRm1Oak5rTXpRNU9XSTFZV0ZtTVRreE1tUmlObVkxWlFBTU0wTkNRWFZ2YVZsVE0zTTlBQU5oZHpFIiwiZXhwIjoxNTYwNzc3MTQzLCJpYXQiOjE1NjA3Njk5NDMsImFpZCI6IndtM0FMdXlJVGYyMkNrT2kwR2xnV3ciLCJjaWQiOiIifQ.IY50N-gN0ssUFemexrguBfZHOut8Pfd4ih_e8l6XOWQ”,
“status”: “waiting”,
“timezone”: “America/Los_Angeles”,
“topic”: “Test Meeting of Recurssive meeting in Browser”,
“type”: 8,
“uuid”: “8VbuBK4+RZqb45OgsPs71g==”
}

We would like to understand why in the response body the start_time is not as the same as the start_time mentioned in the request body. The start_time is actually the creation time of the request.

May be we are missing something. We want to pass the start date time of the meeting. How to do that ?

Thanks,
Amit

@z.zoom.zoom.zoom.zoo,

I am currently working on this issue, and will provide you with an update shortly.

Thanks!

Thank you Ojus …

Regards,
Amit

Hi Ojus,
Is there any update? We need to push this one.

Thanks,
Amit

Hi @z.zoom.zoom.zoom.zoo,

It seems that the value for the start_time that you provided is invalid. In your case, the correct value for the start time would be 2019-07-30T21:00:00Z and the correct value for end time would be 2019-08-30T21:00:00Z

Please note that in your body, you have provided that the meeting will end after occurring for 12 times, so, the last date for the meeting would be 2019-09-10, irrespective of the 2019-08-30T21:00:00 end time given by you.

For more information, please visit: https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingcreate

Thanks!

Hi Ojus,
Thank you for the input. We need little more clarification. Please see the Request body as below

{
“topic”: “Toipc of meeting”,
“type”: “8”,
“start_time”: “2019-07-30T21:00:00”,
“duration”: “60”,
“timezone”: “America/Los_Angeles”,
“agenda”: “Agenda of meeting”,
“recurrence”: {
“type”: “2”,
“repeat_interval”: “1”,
“weekly_days”: “1”,
“end_date_time”: “2019-08-15T21:00:00”
},
“settings”: {
“host_video”: “false”,
“participant_video”: “false”,
“join_before_host”: “true”,
“mute_upon_entry”: “false”,
“watermark”: “true”,
“use_pmi”: “false”,
“approval_type”: “0”,
“registration_type”: “1”,
“audio”: “both”,
“auto_recording”: “true”,
“enforce_login”: “false”,
“enforce_login_domains”: “false”,
“alternative_hosts”: “”
}
}

The Response we received as

{
“agenda”: “Agenda of meeting”,
“created_at”: “2019-06-20T06:23:40Z”,
“host_id”: “MfZlTyOrSI22Wa__riEfvw”,
“id”: 594897654,
“join_url”: “https://zoom.us/j/594897654”,
“occurrences”: [
{
“duration”: 60,
“occurrence_id”: “1564977600000”,
“start_time”: “2019-08-05T04:00:00Z”,
“status”: “available”
}
],
“recurrence”: {
“end_date_time”: “2019-08-06T13:23:00Z”,
“repeat_interval”: 1,
“type”: 2,
“weekly_days”: “1”
},
“settings”: {
“alternative_hosts”: “”,
“approval_type”: 2,
“audio”: “both”,
“auto_recording”: “none”,
“close_registration”: true,
“cn_meeting”: false,
“contact_email”: "zoom.integration.kr@gmail.com",
“contact_name”: “Zoom Kumar”,
“enforce_login”: false,
“enforce_login_domains”: “”,
“global_dial_in_countries”: [
“US”
],
“host_video”: false,
“in_meeting”: false,
“join_before_host”: true,
“mute_upon_entry”: false,
“participant_video”: false,
“registrants_confirmation_email”: true,
“use_pmi”: false,
“waiting_room”: false,
“watermark”: true
},
“start_url”: “https://zoom.us/s/594897654?zak=eyJhbGciOiJIUzI1NiJ9.eyJhdWQiOiJjbGllbnQiLCJ1aWQiOiJNZlpsVHlPclNJMjJXYV9fcmlFZnZ3IiwiaXNzIjoid2ViIiwic3R5IjoxMDAsIndjZCI6ImF3MSIsImNsdCI6MCwic3RrIjoiU2Zpd0tRU0ctUkRwSDQtVXJVSUJ0anR0MkJNdVc0NlFhS3ZkQW93T05uQS5CZ1VzU2s4M0wxbFZiVWs0VHk5cmVVZEhWbkpWUXpCV1pIQkxNVTVGVkdwbmNWTkVNbmh6Y21wak9GRlNhejFBTmpVNU1tUTBPVEF3TWpObU9UUTBOekV5T1dJNE5EUXhaVGc0T0RRMk1qRTRNakV5WmpnNE5XRm1Oak5rTXpRNU9XSTFZV0ZtTVRreE1tUmlObVkxWlFBTU0wTkNRWFZ2YVZsVE0zTTlBQU5oZHpFIiwiZXhwIjoxNTYxMDE5MDIwLCJpYXQiOjE1NjEwMTE4MjAsImFpZCI6IndtM0FMdXlJVGYyMkNrT2kwR2xnV3ciLCJjaWQiOiIifQ.vVvvvWCD22_juTVxsZFICAG1o7ySUSBdLq-Bh3Kc8bY”,
“status”: “waiting”,
“timezone”: “America/Los_Angeles”,
“topic”: “Toipc of meeting”,
“type”: 8,
“uuid”: “QBRzJ4a5QUyXOWYJAuXgeg==”
}

Please notice that the start date time is given as per the suggestion. The Start Date time is - 2019-07-30T21:00:00 and End Date time is - 2019-08-15T21:00:00.
We did not provide any end_times as we supposed it’s not required because we are giving the End Date time. Same as we schedule Recurrence meetings from Zoom portal UI.

Now, we expect, two Occurrences. First on 5th Aug 2019 at 21:00:00 and another at 12th Aug 2019 at 21:00:00. We provided

“recurrence”: {
“type”: “2”,
“repeat_interval”: “1”,
“weekly_days”: “1”,
“end_date_time”: “2019-08-15T21:00:00”
},

But as you notice in the Response body, the expectations are not in sync.
Are we missing something ?
Please provide your guidance on this

Thanks,
Amit

Hi @z.zoom.zoom.zoom.zoo,

The end_date_time should be in UTC time, for e.g:2019-08-15T21:00:00Z, my apologies, I should have clarified in the above post. Please do not use UTC time for start_time.

Here is the request body for you:

{
“topic”: “Toipc of meeting”,
“type”: “8”,
“timezone”: “America/Los_Angeles”,
“start_time”: “2019-07-30T21:00:00”,
“duration”: “60”,
“agenda”: “Agenda of meeting”,
“recurrence”: {
“type”: “2”,
“repeat_interval”: “1”,
“weekly_days”: “1”,
“end_date_time”: “2019-08-15T21:00:00Z”
},
“settings”: {
“host_video”: “false”,
“participant_video”: “false”,
“join_before_host”: “true”,
“mute_upon_entry”: “false”,
“watermark”: “true”,
“use_pmi”: “false”,
“approval_type”: “0”,
“registration_type”: “1”,
“audio”: “both”,
“auto_recording”: “true”,
“enforce_login”: “false”,
“enforce_login_domains”: “false”,
“alternative_hosts”: “”
}
}

Let me know if this helps

Thank you Ojus, seems it clarifies our query. Thank you for your help :slight_smile:

Just a thought. May be it requires a little modification in the documentation. If it provides with some examples, it would be great.

Hi @z.zoom.zoom.zoom.zoo,

Thank you for the feedback. Our Team is currently working on revamping the documentation.

Cheers!